您的位置:首页 > 其它

Substrings

2015-12-25 22:05 363 查看
原楼主博客链接

十分感谢链接地址楼主的分享

以下博客是本人的理解

Description

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings. 

 

Input

The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the
number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 

 

Output

There should be one line per test case containing the length of the largest string found. 

 

Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid

 

Sample Output

2
2

原题目意思是叫你求出所给的每一种情况下,多个字符串中存在的最大的连续的字符串长度,但是有一个很坑的条件,就是这些字符串可以是逆序的,而且所给的字符串的

长度不确定,因此首先你必须要找出最短的字符串,然后再用两个for循环求出这个最短字符串中所包含的所有子字符串,以及这些子字符串的逆序,用

strstr函数判断这些子字符串是否包含于另外的每一个所给的字符串,并求出最长的符合要求的子字符串,输出这个子字符串的长度就是所求的输出结果

另外不懂strstr的用法的小伙伴:strstr用法 

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
char a[105][105];
char b[105];
char c[105];
int main()
{
int i,j,k,l,t;
int len;
int num,n;
int max,min;
int flag;
scanf("%d",&num);
while(num--){
scanf("%d",&n);
min=1000;
t=0;
for(i=0;i<n;i++){//求出最小字符串
scanf("%s",a[i]);
len=strlen(a[i]);
if(min>len){
min=len;
t=i;
}
}
len=strlen(a[t]);
max=0;
//t=min;
flag=1;
for(i=0;i<len;i++){
for(j=i;j<len;j++){
flag=1;
for(k=i;k<=j;k++){//求出最短字符串所包含的所有子字符串以及它的顺序逆序
b[k-i]=a[t][k];
c[j-k]=a[t][k];
}
b[j-i+1]=c[j-i+1]='\0';
l=strlen(b);
for(k=0;k<n;k++){
if(!strstr(a[k],b)&&!strstr(a[k],c)){//比较子字符串是否包含于所给出的其他字符串
flag=0;
break;
}
}
if(l>max&&flag) max=l;
flag=1;
}
}
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息