您的位置:首页 > 其它

HDOJ 4288 Coder (离线处理 + 线段树)

2015-12-21 21:29 267 查看


Coder

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4786    Accepted Submission(s): 1828


Problem Description

  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write
an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done. 1

  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).

Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.

  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:

  1. add x – add the element x to the set;

  2. del x – remove the element x from the set;

  3. sum – find the digest sum of the set. The digest sum should be understood by



  where the set S is written as {a1, a2, ... , ak} satisfying a1 < a2 < a3 < ... < ak 

  Can you complete this task (and be then fired)?

------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 

Input

  There’re several test cases.

  In each test case, the first line contains one integer N ( 1 <= N <= 105 ), the number of operations to process.

  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.

  You may assume that 1 <= x <= 109.

  Please see the sample for detailed format.

  For any “add x” it is guaranteed that x is not currently in the set just before this operation.

  For any “del x” it is guaranteed that x must currently be in the set just before this operation.

  Please process until EOF (End Of File).

 

Output

  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.

 

Sample Input

9
add 1
add 2
add 3
add 4
add 5
sum
add 6
del 3
sum
6
add 1
add 3
add 5
add 7
add 9
sum

 

Sample Output

3
4
5
HintC++ maybe run faster than G++ in this problem.

 

Source

2012 ACM/ICPC Asia Regional Chengdu Online

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 100010;
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
typedef long long LL;

struct node{
int cnt;
LL sum[5];
}tree[N << 2];

void push_up(int rt) {
tree[rt].cnt = tree[rt << 1].cnt + tree[rt << 1 | 1].cnt;
for (int i = 0; i < 5; ++i) {
int j = (i + 5 - tree[rt << 1].cnt % 5) % 5;
tree[rt].sum[i] = tree[rt << 1].sum[i] + tree[rt << 1 | 1].sum[j];
}
}

void build(int l, int r, int rt) {
if (l == r) {
memset(tree + rt, 0, sizeof(node));
return;
}
int m = (l + r) >> 1;
build(lson);
build(rson);
push_up(rt);
}

void update(int id, int x, int l, int r, int rt) {
if (l == r) {
tree[rt].cnt = !tree[rt].cnt;
tree[rt].sum[1] = x * tree[rt].cnt;
return ;
}
int m = (l + r) >> 1;
if (id <= m) update(id, x, lson);
else update(id, x, rson);
push_up(rt);
}

int main() {
int n;
char op
, str[5];
int num
, id
;
while (~scanf("%d", &n)) {
build(1, n, 1);
for (int i = 0; i < n; ++i) {
scanf("%s", str);
op[i] = str[0];
if (str[0] != 's') scanf("%d", num + i);
else num[i] = 0;
id[i] = num[i];
}
sort(id, id + n);
for (int i = 0; i < n; ++i) {
if (op[i] != 's') update(lower_bound(id, id + n, num[i]) - id + 1, num[i], 1, n, 1);
else printf("%lld\n", tree[1].sum[3]);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: