您的位置:首页 > 其它

hdu1028 Ignatius and the Princess III (完全背包)

2015-12-18 17:00 232 查看


Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16474    Accepted Submission(s): 11609

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:

  N=a[1]+a[2]+a[3]+...+a[m];

  a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

  4 = 4;

  4 = 3 + 1;

  4 = 2 + 2;

  4 = 2 + 1 + 1;

  4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

 

Sample Input

4
10
20

 

Sample Output

5
42
627

 

Author

Ignatius.L

 

Recommend

We have carefully selected several similar problems for you:  1171 1085 1398 2152 1709 

 

代码:

#include<cstdio>
#include<cstring>
#define ms(a) memset(a,0,sizeof(a))
using namespace std;

const int maxn=120;
int f[maxn+10];

int main()
{
freopen("1.in","r",stdin);

int n,i,j;
ms(f),f[0]=1;
for(i=1;i<=maxn;i++)
for(j=i;j<=maxn;j++)f[j]+=f[j-i];
while(scanf("%d",&n)==1)printf("%d\n",f
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: