您的位置:首页 > 其它

uva 103

2015-12-17 20:36 169 查看
B - Stacking Boxes
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld
& %llu
SubmitStatusPracticeUVA
103

Appoint description:

Description



Background

Some concepts in Mathematics and Computer Science are simple in one or two dimensions but become more complex when extended to arbitrary dimensions. Consider solving differential equations in several dimensions and analyzing the topology of ann-dimensional
hypercube. The former is much more complicated than its one dimensional relative while the latter bears a remarkable resemblance to its ``lower-class'' cousin.

The Problem

Consider an n-dimensional ``box'' given by its dimensions. In two dimensions the box (2,3) might represent a box with length 2 units and width 3 units. In three dimensions the box (4,8,9) can represent a box


(length, width, and height). In 6 dimensions it is, perhaps, unclear what the box (4,5,6,7,8,9) represents; but we can analyze properties of the box such as the sum of its dimensions.

In this problem you will analyze a property of a group of n-dimensional boxes. You are to determine the longestnesting string of boxes, that is a sequence of boxes


such that each box


nests in box

(


.

A box D = (

) nests in a box E = (


) if there is some rearrangement of the

such that when rearranged each dimension is less than the corresponding
dimension in box E. This loosely corresponds to turning box D to see if it will fit in box E. However, since any rearrangement suffices, box D can be contorted, not just turned (see examples below).

For example, the box D = (2,6) nests in the box E = (7,3) since D can be rearranged as (6,2) so that each dimension is less than the corresponding dimension in E. The box D = (9,5,7,3) does NOT nest in the box E = (2,10,6,8) since no rearrangement of D results
in a box that satisfies the nesting property, but F = (9,5,7,1) does nest in box E since F can be rearranged as (1,9,5,7) which nests in E.

Formally, we define nesting as follows: box D = (

)nests in box E = (


) if there is a permutation


of

such that (


) ``fits'' in (

) i.e., if


for all

.

The Input

The input consists of a series of box sequences. Each box sequence begins with a line consisting of the the number of boxesk in the sequence followed by the dimensionality of the boxes,
n (on the same line.)

This line is followed by k lines, one line per box with the n measurements of each box on one line separated by one or more spaces. The


line in the sequence (

) gives the measurements for the


box.

There may be several box sequences in the input file. Your program should process all of them and determine, for each sequence, which of thek boxes determine the longest nesting string and the length of that nesting string (the number of boxes in
the string).

In this problem the maximum dimensionality is 10 and the minimum dimensionality is 1. The maximum number of boxes in a sequence is 30.

The Output

For each box sequence in the input file, output the length of the longest nesting string on one line followed on the next line by a list of the boxes that comprise this string in order. The ``smallest'' or ``innermost'' box of the nesting string should be
listed first, the next box (if there is one) should be listed second, etc.

The boxes should be numbered according to the order in which they appeared in the input file (first box is box 1, etc.).

If there is more than one longest nesting string then any one of them can be output.

Sample Input

5 2
3 7
8 10
5 2
9 11
21 18
8 6
5 2 20 1 30 10
23 15 7 9 11 3
40 50 34 24 14 4
9 10 11 12 13 14
31 4 18 8 27 17
44 32 13 19 41 19
1 2 3 4 5 6
80 37 47 18 21 9

Sample Output

5
3 1 2 4 5
4
7 2 5 6

做dp  感觉还是无从下手
题解都要研究老半天
每行数据要先排序
接着是记录i j行的大小关系   map
记忆搜索dp  把每行被几个包都记录下来  d[]
打印

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int n, k;
int map[35][35], d[35], num[35][35];

int max(int a, int b){
return a > b ? a : b;
}

int cmp(const void *a, const void *b){
return (*(int *)a - *(int *)b);
}

int isbigger(int a, int b){
for (int i = 0; i < k; i++)
if (num[a][i] >= num[b][i])
return 0;
return 1;
}
int dp(int i){
if (d[i] > 0)
return d[i];
int &ans = d[i] = 1;
for (int j = 0; j < n; j++)
if (map[i][j])
ans = max(ans, dp(j) + 1);
return ans;
}

int print(int i){
printf("%d", i + 1);
for (int j = 0; j < n; j++)
if (map[i][j] && d[i] == d[j] + 1) {
printf(" ");
print(j);
break;
}
}

int main(){
while (scanf("%d%d", &n, &k) != EOF) {
for (int i = 0; i < n; i++) {
for (int j = 0; j < k; j++)
scanf("%d", &num[i][j]);
qsort(num[i], k, sizeof(num[i][0]), cmp);
}
memset(map, 0, sizeof(map));
memset(d, 0, sizeof(d));

for (int i = 0; i < n - 1; i++)
for (int j = i + 1; j < n; j++) {
if (isbigger(i, j))
map[i][j] = 1;
else if (isbigger(j, i))
map[j][i] = 1;
}
int max = 0, pos = 0;
for (int i = 0; i < n; i++) {
int a = dp(i);
if (a > max) {
max = a;
pos = i;
}
}
printf("%d\n", max);
print(pos);
printf("\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: