您的位置:首页 > 其它

POJ 3176 Cow Bowling(简单DP)

2015-12-16 14:29 337 查看

[align=center]Cow Bowling[/align]

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 15952
Accepted: 10626
Description
The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

7

3   8

8   1   0

2   7   4   4

4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along
the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input
Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output
Line 1: The largest sum achievable using the traversal rules
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

Hint
Explanation of the sample: 

7

*

3   8

*

8   1   0

*

2   7   4   4

*

4   5   2   6   5


The highest score is achievable by traversing the cows as shown above.

题意:和HDOJ的数塔一模一样啦,从顶层部开始走,每一层取一个数,且必须以向正下方或者斜下方走,问走到底层,数字相加的和最大是多少。

代码如下:

#include<cstdio>
#include<cstring>
int map[360][360];
int main()
{
int n,i,j;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;++i)
{
for(j=0;j<=i;++j)
scanf("%d",&map[i][j]);
}
for(i=n-2;i>=0;--i)
{
for(j=0;j<=i;++j)
map[i][j]+=map[i+1][j]>map[i+1][j+1]?map[i+1][j]:map[i+1][j+1];
}
printf("%d\n",map[0][0]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: