您的位置:首页 > 其它

POJ 3009 Curling 2.0(dfs)

2015-12-20 11:52 197 查看
[align=center]Curling 2.0[/align]

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 15474
Accepted: 6400
Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single
stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone
begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.



Fig. 1: Example of board (S: start, G: goal)
The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.

The stone gets out of the board.
The game ends in failure.

The stone reaches the goal square.
The stone stops there and the game ends in success.

You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.



Fig. 2: Stone movements
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed
as in Fig. 3(b).



Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board 

... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position
The dataset for Fig. D-1 is as follows:

6 6 

1 0 0 2 1 0 

1 1 0 0 0 0 

0 0 0 0 0 3 

0 0 0 0 0 0 

1 0 0 0 0 1 

0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other
than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output
1
4
-1
4
10
-1


题意:在一个m*n的方格中,要将小石子从起点(2)移动到终点(3),小石子只能朝一个方向移动,只有碰到木箱时才会停下来,并将木箱(1)击碎,然后再朝允许移动的方向移动,直到到达终点位置但静止的小石子与木箱相邻时,小石子是不能向箱子的方向移动的。问小石子最少移动的次数,若小石子无法到达终点,或到达重点的移动次数超过10次,输出-1。

题解:和普通的深度优先遍历不同的地方是每一次向下一步走去时,若没有碰到障碍物,是必须继续按这个方向走下去的。且求的是最少移动次数,也就是可能当前到达终点的路径不是最优路径,所以不能把走过的格子标记,且每一条路线走结束后,要还原被撞碎的木箱。在朝一个方向移动时,我们可以用一个while循环控制,直到遇见木箱时,才跳出循环。

代码如下:

#include<cstdio>
#include<cstring>
int map[110][110];
int dir[4][2]={{1,0},{-1,0},{0,-1},{0,1}};
int n,m,s_n,s_m;
int ans;

int min(int a,int b)
{
return a>b?b:a;
}

void dfs(int x,int y,int z)
{
int i,sign,nx,ny;
if(z>10)//超出步数限制
return ;
for(i=0;i<4;++i)
{
nx=x; ny=y;
if(map[nx+dir[i][0]][ny+dir[i][1]]==1)//与木箱相邻,则不能朝木箱方向移动
continue;
sign=0;
while(1)
{
nx+=dir[i][0];
ny+=dir[i][1];
if(0>nx||nx>=n||0>ny||ny>=m)
{
sign=1;
break;
}
if(map[nx][ny]==1)
break;
else if(map[nx][ny]==3)
{
ans=min(ans,z+1);//注意,此处移动次数应该是z+1
return ;
}
}
if(!sign)
{
map[nx][ny]=0;
dfs(nx-dir[i][0],ny-dir[i][1],z+1);
map[nx][ny]=1;
}
}
}

int main()
{
int i,j;
while(scanf("%d%d",&m,&n)&&m||n)
{
for(i=0;i<n;++i)
{
for(j=0;j<m;++j)
{
scanf("%d",&map[i][j]);
if(map[i][j]==2)
{
s_n=i;
s_m=j;
map[i][j]=0;//记录下起点后,将其还原为空格
}
}
}
ans=11;
dfs(s_n,s_m,0);
if(ans>10)
printf("-1\n");
else
printf("%d\n",ans);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: