您的位置:首页 > 其它

hdu2199 Can you solve this equation? (二分+double精度)

2015-12-12 15:31 405 查看


Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 14274    Accepted Submission(s): 6359

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

 

Sample Input

2
100
-4

 

Sample Output

1.6152
No solution!

 

Author

Redow

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2899 2289 2298 2141 3400 

 

解析:注意精度,我这里去的时候1e-6。

代码:

#include<cstdio>
#include<cmath>
using namespace std;

double precision=1e-6;
double y;

double f(double x)
{
return 8*pow(x,4.0)+7*pow(x,3.0)+2*pow(x,2.0)+3*x;
}

int main()
{
//freopen("1.in","r",stdin);

int t; double l,r,mid;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y),y-=6;
if(y<0||y>807020300)
{
printf("No solution!\n");
continue;
}

l=0,r=100;
while(r-l>=precision)
{
mid=(l+r)/2;
if(f(mid)<=y)l=mid;
else r=mid;
}
printf("%.4lf\n",(l+r)/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: