您的位置:首页 > 产品设计 > UI/UE

HDU ACM 3177 Crixalis's Equipment [贪心][差值排序]

2015-12-08 10:39 447 查看

原题描述

Problem Description

Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he’s a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it’s just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.

Input

The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.

0

Output

For each case output “Yes” if Crixalis can move all his equipment into the new hole or else output “No”.

Sample Input

2

20 3

10 20

3 10

1 7

10 2

1 10

2 11

Sample Output

Yes

No

解题思路

题意:蝎子要将多件装备搬进洞里,装备有一个空间A和一个移动时的空间B,洞的容量大于移动时的空间才能将装备放入,放入以后只占据A空间。问能不能将所有装备都放入洞。

思路:

两装备X,Y如果要放入洞,先X再Y,所需要的空间是max(XB,XA+YB)

先Y再X,所需要的空间是max(YB,YA+XB)

所以就是要求min[max(XB,XA+YB),max(YB,YA+XB)],哪个小就先放哪个

进而求XA+YB与YA+XB的大小比较

若XA+YB < YA+XB就先放X

即YA-XA > YB-XB就先放X

所以将所有装备按照B与A的差值从大到小排序,然后遍历放入洞。如果遍历到有一个放不进,则无法全部放入。

参考代码

#include <iostream>
#include <algorithm>
using namespace std;

struct item
{
int A, B, C;
}I[1010];

bool comp(item a,item b)            // 按照B-A的差值,从大到小排序
{
return (a.B - a.A) > (b.B - b.A);
}

int main()
{
int T, V, N;
bool flag;
scanf("%d", &T);
while (T--)
{
flag = true;
scanf("%d%d", &V, &N);
for (int i = 0; i < N;i++)
{
scanf("%d%d", &I[i].A, &I[i].B);
}
sort(I, I + N, comp);
for (int i = 0; i < N;i++)
{
if(V>=I[i].B)
{
V -= I[i].A;
}
else
{
flag = false;
break;
}
}
if (flag)
printf("Yes\n");
else
printf("No\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: