您的位置:首页 > 其它

hdu2602 Bone Collector (01背包)

2015-12-07 22:07 323 查看


Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 42517    Accepted Submission(s): 17708

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

 

Author

Teddy

 

Source

HDU 1st “Vegetable-Birds Cup” Programming
Open Contest

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1203 2159 2955 1171 2191 

 

解析:01背包裸题。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ms(a) memset(a,0,sizeof(a))
using namespace std;

const int maxn=1e3;
int w[maxn+10],v[maxn+10];
int f[maxn+10];

int main()
{
freopen("1.in","r",stdin);

int t,n,sv,i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&sv);
for(i=1;i<=n;i++)scanf("%d",&v[i]);
for(i=1;i<=n;i++)scanf("%d",&w[i]);
for(ms(f),i=1;i<=n;i++)
for(j=sv;j>=w[i];j--)
f[j]=max(f[j],f[j-w[i]]+v[i]);
printf("%d\n",f[sv]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: