您的位置:首页 > 其它

How many prime numbers

2015-12-06 16:06 316 查看

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9909 Accepted Submission(s): 3215
Problem Description

Give you a lot of positive integers, just to find out how many prime numbers there are.
 

Input

There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 

Output

            For each case, print the number of prime numbers you have found out.
 

Sample Input

3
2 3 4


 

Sample Output

2


 

Author

wangye
 

Source

HDU 2007-11 Programming Contest_WarmUp
 

Recommend

威士忌
#include<iostream>
#include<math.h>

using namespace std;

bool IsPrimeNum(unsigned int val)
{
int tmp=sqrt(val);
for(int i=2;i<=tmp;i++)
{
if(val%i==0)
return false;
}
return true;
}

int main()
{
int num,result=0;
unsigned int i=0;

while(cin>>num)
{
while(num--)
{
cin>>i;
if(i==1)
continue;
else if(IsPrimeNum(i))
result++;
}
cout<<result<<endl;
result=0;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  判断素数