您的位置:首页 > 产品设计 > UI/UE

HDU-5538-House Building【2015长春赛区】

2015-12-05 08:59 363 查看

HDU-5538-House Building【2015长春赛区】

[code]            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)


Problem Description

Have you ever played the video game Minecraft? This game has been one of the world’s most popular game in recent years. The world of Minecraft is made up of lots of 1×1×1 blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, … or even a building material such as brick or concrete in this game.



Figure 1: A typical world in Minecraft.

Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it’s really a lovely place to build houses on it. Nyanko-san decided to build on a n×m big flat ground, so he drew a blueprint of his house, and found some building materials to build.

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.

There are n rows and m columns on the ground, an intersection of a row and a column is a 1×1 square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san’s blueprint can be represented as an integer array ci,j(1≤i≤n,1≤j≤m). Which ci,j indicates the height of his house on the square of i-th row and j-th column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san’s house(exclude the face adjacent to the ground).

Input

The first line contains an integer T indicating the total number of test cases.

First line of each test case is a line with two integers n,m.

The n lines that follow describe the array of Nyanko-san’s blueprint, the i-th of these lines has m integers ci,1,ci,2,…,ci,m, separated by a single space.

1≤T≤50

1≤n,m≤50

0≤ci,j≤1000

Output

For each test case, please output the number of glass units you need to collect to meet Nyanko-san’s requirement in one line.

Sample Input

2

3 3

1 0 0

3 1 2

1 1 0

3 3

1 0 1

0 0 0

1 0 1

Sample Output

30

20



题目链接:HDU-5538

题目大意:给出n*m的一个区域每个格子放的立方体的个数(1*1*1)求总共的表面积。

题目思路:算出独立表面积总和然后减去相接部门的表面积。

以下是代码:

[code]#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
int g[60][60]; 
int main(){
    int t;
    cin >> t;
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int sum = 0;
        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < m; j++)
            {
                scanf("%d",&g[i][j]);
                sum += g[i][j];
            }
        }
        sum *= 5;
        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < m; j++)
            {
                if (g[i][j] != 0)
                {
                    if (i < n - 1)
                    {
                        if (g[i+1][j]) sum -= min(g[i+1][j],g[i][j]);
                    }
                    if (i > 0)
                    {
                        if (g[i-1][j]) sum -= min(g[i-1][j],g[i][j]);
                    }
                    if (j > 0)
                    {
                        if (g[i][j-1]) sum -= min(g[i][j-1],g[i][j]);
                    }
                    if (j < m - 1)
                    {
                        if (g[i][j+1]) sum -= min(g[i][j+1],g[i][j]);
                    }
                    if (g[i][j] > 1)
                    {
                        sum = sum - g[i][j] + 1;
                    } 
                }
            }
        }
        cout << sum << endl;
    } 
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: