您的位置:首页 > 产品设计 > UI/UE

HDUOJ Number Sequence找规律

2015-12-04 17:30 615 查看


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 137304    Accepted Submission(s): 33277


Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

1 1 3
1 2 10
0 0 0

 

Sample Output

2
5

 

Author

CHEN, Shunbao

 

Source

ZJCPC2004

找规律,让循环自己找到它的循环周期,然后按照循环的周期去处理数据,减少运行时间。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

#include<stdio.h>
int f[100000010];
int main()
{
int a,b,n,i,j,s;
f[1]=f[2]=1;
while(scanf("%d%d%d",&a,&b,&n)&&a+b+n)
{
s=0;
for(i=3; i<=n; i++)
{
f[i]=(f[i-1]*a+f[i-2]*b)%7;
for(j=2; j<i; j++)
if(f[i-1]==f[j-1]&&f[i]==f[j])
{
s=i-j;
break;
}
if(s>0)
break;
}
if(s>0)
f[n]=f[(n-j)%s+j];
printf("%d\n",f[n]);
}
return 0;
}


大神的代码,实在看不懂啊!以后再好好研究吧

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

#include<stdio.h>
#include<iostream>
using namespace std;
int main()
{
int a,b,n,i,j;
while(scanf("%d%d%d",&a,&b,&n)&&a+b+n)
{
int f[2]= {1,1};
for(i=0; i<(n%49-1)/2; i++)
{
f[0]=(a*f[1]+b*f[0])%7;
f[1]=(a*f[0]+b*f[1])%7;
}
if(n%2)
printf("%d\n",f[0]);
else
printf("%d\n",f[1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: