您的位置:首页 > 大数据 > 人工智能

poj3757 Training little cats

2015-12-04 15:56 441 查看
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11496 Accepted: 2815
Description

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the
cats to do his exercises. Facer's great exercise for cats contains three different moves:

g i : Let the ith cat take a peanut.

e i : Let the ith cat eat all peanuts it have.

s i j : Let the ith cat and jth cat exchange their peanuts.

All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. 

You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers n, m and k are given firstly, where n is the number of cats and k is the length of the move
sequence. The following klines describe the sequence.

(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input
3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output
2 0 1
题意:
有n只猫咪,开始时每只猫有花生0颗,现有m组重复操作,每组由下面三个中的k个操作组成:
               1. g i 给i只猫咪一颗花生米
               2. e i 让第i只猫咪吃掉它拥有的所有花生米
               3. s i j 将猫咪i与猫咪j的拥有的花生米交换

               m次后,每只猫咪有多少颗花生?

可以构建一个1*(n+1)大小的辅助矩阵,即1 0 0 0,然后根据操作构造转置矩阵。

转置矩阵的构造:

转置矩阵一开始初始化为(n+1)*(n+1)大小的单位矩阵,然后每一次操作都要变化。

1.g i 第0行第i列的元素加1

2.e i 第i列的元素都变为0

3.s i j 第i列和第j列的元素都换一下

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 99999999
#define pi acos(-1.0)

struct matrix{
ll n,m,i;
ll data[105][105];
void init_danwei(){
for(i=0;i<n;i++){
data[i][i]=1;
}
}
};

matrix multi(matrix &a,matrix &b){
ll i,j,k;
matrix temp;
temp.n=a.n;
temp.m=b.m;
for(i=0;i<temp.n;i++){
for(j=0;j<temp.m;j++){
temp.data[i][j]=0;
}
}
for(i=0;i<a.n;i++){
for(k=0;k<a.m;k++){
if(a.data[i][k]>0){
for(j=0;j<b.m;j++){
temp.data[i][j]=temp.data[i][j]+a.data[i][k]*b.data[k][j];
}
}
}
}
return temp;
}

matrix fast_mod(matrix &a,ll n){
matrix ans;
ans.n=a.n;
ans.m=a.m;
memset(ans.data,0,sizeof(ans.data));
ans.init_danwei();
while(n>0){
if(n&1)ans=multi(ans,a);
a=multi(a,a);
n>>=1;
}
return ans;
}

int main()
{
ll n,k,m,i,j,e,c,d,h;
while(scanf("%lld%lld%lld",&n,&m,&k)!=EOF)
{
if(n==0 && m==0 && k==0)break;
matrix a;
a.n=a.m=n+1;
memset(a.data,0,sizeof(a.data));
a.init_danwei();

char s[10];
ll temp;
for(i=1;i<=k;i++){
scanf("%s",s);
if(s[0]=='g'){
scanf("%lld",&c);
a.data[0][c]++;
}
else if(s[0]=='s'){
scanf("%lld%lld",&c,&d);
for(j=0;j<n+1;j++){
temp=a.data[j][c];
a.data[j][c]=a.data[j][d];
a.data[j][d]=temp;
}
}
else if(s[0]=='e'){
scanf("%lld",&c);
for(j=0;j<n+1;j++){
a.data[j][c]=0;
}

}
}

matrix cnt;
cnt=fast_mod(a,m);
matrix ant;
ant.n=1;
ant.m=n+1;
memset(ant.data,0,sizeof(ant.data));
ant.data[0][0]=1;

matrix juzhen;
juzhen=multi(ant,cnt);

for(i=1;i<=n;i++){
if(i==n)printf("%lld\n",juzhen.data[0]
);
else printf("%lld ",juzhen.data[0][i]);
}

}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: