您的位置:首页 > 其它

杭电5499 SDOI

2015-12-03 20:40 344 查看


SDOI

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 691    Accepted Submission(s): 271


Problem Description

The Annual National Olympic of Information(NOI) will be held.The province of Shandong hold a Select(which we call SDOI for short) to choose some people to go to the NOI. n(n≤100) people
comes to the Select and there is m(m≤50) people
who can go to the NOI.

According to the tradition and regulation.There were two rounds of the SDOI, they are so called "Round 1" and "Round 2", the full marks of each round is 300.

All the n people take part in Round1 and Round2, now the original mark of every person is known. The rule of SDOI of ranking gets to the "standard mark". For each round there is a highest original mark,let's assume that is x.(it
is promised that not all person in one round is 0,in another way,x>0).
So for this round,everyone's final mark equals to his/her original mark∗(300/x).

After we got everyone's final mark in both round.We calculate the Ultimate mark of everyone as 0.3∗round1′s final
mark + 0.7∗round2′s final
mark.It is so great that there were no two persons who have the same Ultimate mark.

After we got everyone's Ultimate mark.We choose the persons as followed:

To encourage girls to take part in the Olympic of Information.In each province,there has to be a girl in its teams.

1. If there is no girls take part in SDOI,The boys with the rank of first m enter the team.

2. If there is girls, then the girl who had the highest score(compared with other girls) enter the team,and other(boys and other girls) m-1 people with the highest mark enter the team.

Just now all the examination had been finished.Please write a program, according to the input information of every people(Name, Sex ,The original mark of Round1 and Round2),Output the List of who can enter the team with their Ultimate mark decreasing.

 

Input

There is an integer T(T≤100) in
the first line for the number of testcases and followed T testcases.

For each testcase, there are two integers n and m in
the first line(n≥m),
standing for the number of people take part in SDOI and the allowance of the team.Followed with n lines,each
line is an information of a person. Name(A string with length less than 20,only
contain numbers and English letters),Sex(male or female),the Original mark of Round1 and Round2 (both equal to or less than 300)
separated with a space.

 

Output

For each testcase, output "The member list of Shandong team is as follows:" without Quotation marks.

Followed m lines,every
line is the name of the team with their Ultimate mark decreasing.

 

Sample Input

2
10 8
dxy male 230 225
davidwang male 218 235
evensgn male 150 175
tpkuangmo female 34 21
guncuye male 5 15
faebdc male 245 250
lavender female 220 216
qmqmqm male 250 245
davidlee male 240 160
dxymeizi female 205 190
2 1
dxy male 300 300
dxymeizi female 0 0

 

Sample Output

The member list of Shandong team is as follows:
faebdc
qmqmqm
davidwang
dxy
lavender
dxymeizi
davidlee
evensgn
The member list of Shandong team is as follows:
dxymeizi

Hint
For the first testcase: the highest mark of Round1 if 250,so every one's mark times(300/250)=1.2, it's same to Round2.
The Final of The Ultimate score is as followed
faebdc 298.20
qmqmqm 295.80
davidwang 275.88
dxy 271.80
lavender 260.64
dxymeizi 233.40
davidlee 220.80
evensgn 201.00
tpkuangmo 29.88
guncuye 14.40

For the second testcase,There is a girl and the girl with the highest mark dxymeizi enter the team, dxy who with the highest mark,poorly,can not enter the team.

 

Source

BestCoder Round #59 (div.2)

 

Recommend

hujie   |   We have carefully selected several similar problems for you:  5589 5588 5587 5586 5585 

 
结构体水题,这两天心情稍微 有点小缓和 ,做两道水题:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
char name[1100];
int sex;
double mark1;//round 1
double mark2;//round 2
double mark3;//scoor;
}t[110000];
int cmp(node a,node b)
{
return a.mark3 > b.mark3;
}
int i,j,p,m,n,k,l,help;
char s[110];
int main()
{
scanf("%d",&p);
while(p--)
{
scanf("%d%d",&m,&n);
double Max1=0;
double Max2=0;
for(i=0;i<m;i++)
{
scanf("%s%s%lf%lf",t[i].name,s,&t[i].mark1,&t[i].mark2);
if(s[0]=='f')
t[i].sex=0;//gorl
else
t[i].sex=1;//boy
Max1=max(Max1,t[i].mark1);
Max2=max(Max2,t[i].mark2);
}
for(i=0;i<m;i++)
t[i].mark3=t[i].mark1*300/Max1*0.3+t[i].mark2*300/Max2*0.7;
sort(t,t+m,cmp);
int flag=0;
help=-1;
for(i=0;i<n;i++)
if(t[i].sex==0)
flag=1;
for(i=0;i<m;i++)
if(t[i].sex==0)
{
help=i;
break;
}
printf("The member list of Shandong team is as follows:\n");

//
//		for(i=0;i<m;i++)
//		printf("+++%lf\n",t[i].mark3)
if(flag||help==-1)//木有女生或者女生已经选上
for(i=0;i<n;i++)
printf("%s\n",t[i].name);
else//有女生但是没选上
{
for(i=0;i<n-1;i++)
printf("%s\n",t[i].name);
printf("%s\n",t[help].name);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 结构体 排序 hdu