您的位置:首页 > 其它

hdoj Immediate Decodability 1305 (字典树判断前缀)

2015-11-26 20:51 344 查看

Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2397    Accepted Submission(s): 1229


[align=left]Problem Description[/align]
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set
of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:

A:01 B:10 C:0010 D:0000

but this one is not:

A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

[align=left]Input[/align]
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single
separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

[align=left]Output[/align]
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

[align=left]Sample Input[/align]

01
10
0010
0000
9
01
10
010
0000
9

[align=left]Sample Output[/align]

Set 1 is immediately decodable
Set 2 is not immediately decodable//题意:
/*
输入一组数,当输入为‘9’时,表示一组输入结束,判断在这组数据中
是否存在某一个数是其他数的前缀。
和普通的判断字符数组前缀一样,就是输入格式有点坑。。。 
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 10010
using namespace std;
char s
[11];
int ch
[11];
int word
;
int sz;
void insert(char *s)
{
int i,j,l=strlen(s);
int k=0;
for(i=0;i<l;i++)
{
j=s[i]-'0';
if(!ch[k][j])
{
memset(ch[sz],0,sizeof(ch[sz]));
ch[k][j]=sz++;
}
k=ch[k][j];
word[k]++;
}
}
int find(char *s)
{
int i,j,l=strlen(s);
int k=0;
for(i=0;i<l;i++)
{
j=s[i]-'0';
k=ch[k][j];
if(word[k]==1)
return 1;
}
return 0;
}
int main()
{
int n,i,k;
int T=1;
while(~scanf("%s",s[0]))
{
k=1;
while(scanf("%s",s[k++])&&strcmp(s[k-1],"9"));
memset(ch[0],0,sizeof(ch[0]));
memset(word,0,sizeof(word));
sz=1;
for(i=0;i<k;i++)
insert(s[i]);
int flag=1;
for(i=0;i<k;i++)
{
if(!find(s[i]))
{
flag=0;
break;
}
}
if(flag)
printf("Set %d is immediately decodable\n",T++);
else
printf("Set %d is not immediately decodable\n",T++);
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: