您的位置:首页 > 其它

UVa 11729 - Commando War

2015-11-25 09:51 113 查看
“Waiting for orders we held in the wood, word from the front never came

By evening the sound of the gunfire was miles away

Ah softly we moved through the shadows, slip away through the trees

Crossing their lines in the mists in the fields on our hands and our knees

And all that I ever, was able to see

The fire in the air, glowing red, silhouetting the smoke on the breeze”

There is a war and it doesn’t look very promising for your country. Now it’s time to act. You

have a commando squad at your disposal and planning an ambush on an important enemy camp

located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a

unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that

everyone can focus on his task only. In order to enforce this, you brief every individual soldier about

his tasks separately and just before sending him to the battlefield. You know that every single soldier

needs a certain amount of time to execute his job. You also know very clearly how much time you

need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you

need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers

to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his

fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing

in between.

Input

There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤

N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two

integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while

completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case

should not be processed.

Output

For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the

total number of seconds counted from the start of your first briefing till the completion of all jobs.

Sample Input

3

2 5

3 2

2 1

3

3 3

4 4

5 5

0

Sample Output

Case 1: 8

Case 2: 15

代码:

#include<iostream>
#include <string>
#include <algorithm>
using namespace std;
struct dot
{
int n,m;
};
dot s[1005];
int cmp(dot x,dot y)
{return x.m>y.m;}
int main()
{
int i,j,k,a,b,N,p=0;
while(cin>>N&&N)
{  int sum=0,sn;
for(i=0;i<N;i++)
{
cin>>s[i].n>>s[i].m;
sum+=s[i].n;
}
sn=sum;
sort(s,s+N,cmp);
k=0;j=0;
for(i=0;i<N;i++)
{
if(s[i].m>sum-s[i].n&&s[i].m-sum+s[i].n>k)
k=s[i].m-sum+s[i].n;
sum=sum-s[i].n;
}
cout<<"Case "<<++p<<": ";
cout<<sn+k<<endl;
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: