您的位置:首页 > 产品设计 > UI/UE

HDU 4339 Query【线段树】单点更新,动态查询

2015-11-24 17:34 344 查看

Query

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3010 Accepted Submission(s): 964

[align=left]Problem Description[/align]

You are given two strings s1[0..l1], s2[0..l2] and Q - number of queries.
Your task is to answer next queries:
1) 1 a i c - you should set i-th character in a-th string to c;
2) 2 i - you should output the greatest j such that for all k (i<=k and k<i+j) s1[k] equals s2[k].

[align=left]Input[/align]

The first line contains T - number of test cases (T<=25).
Next T blocks contain each test.
The first line of test contains s1.
The second line of test contains s2.
The third line of test contains Q.
Next Q lines of test contain each query:
1) 1 a i c (a is 1 or 2, 0<=i, i<length of a-th string, 'a'<=c, c<='z')
2) 2 i (0<=i, i<l1, i<l2)
All characters in strings are from 'a'..'z' (lowercase latin letters).
Q <= 100000.
l1, l2 <= 1000000.

[align=left]Output[/align]

For each test output "Case t:" in a single line, where t is number of test (numbered from 1 to T).
Then for each query "2 i" output in single line one integer j.

[align=left]Sample Input[/align]

1aaabbaaabbaa 72 0
212 2 2 2 31 1b2 02 3

[align=left]Sample Output[/align]

Case 1:21
10
4
1

本来还感觉自己学的还可以,结果发现自己连递归都控制不好,一直出错,数组下标都弄混了

最后借鉴学长的思路才解决,自己还是迷迷糊糊的..........

找从某个位置处开始两个字符串连续相同的字符的个数........

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[2][1000005];
int sum[4000005];
void build(int rt,int l,int r)//建树没什么说的
{
if(l==r)
{
sum[rt]=0;
if(s[0][r]==s[1][r])
{
sum[rt]=1;
}
return;
}
int mid=(l+r)>>1,tp=rt<<1;
build(tp,l,mid);build(tp|1,mid+1,r);
sum[rt]=sum[tp]+sum[tp|1];
}

void update(int rt,int l,int r,int i)//更新也没什么说的
{
if(l==r)
{
sum[rt]=0;//醉了,卡死在这了,坐标都混了
if(s[0][l]==s[1][l])
{
sum[rt]=1;
}
return;
}
int mid=(l+r)>>1,tp=rt<<1;
if(i<=mid)
{
update(tp,l,mid,i);
}
else
{
update(tp|1,mid+1,r,i);
}
sum[rt]=sum[tp]+sum[tp|1];
}

int find(int rt,int l,int r,int b)
{
if(l==r)//单个元素的时候直接返回
{
return sum[rt];
}
if(b>=l&&b<=r)
{
if(sum[rt]==r-l+1)//一段都相同,直接返回
{
return r-b+1;
}
else
{
int mid=(l+r)>>1,tp=rt<<1,res=0;
if(b<=mid)//查询点在中间点左边,需要讨论
{
res+=find(tp,l,mid,b);//先递归计算左半边有效区域
if(res==mid-b+1)//左边全部为1
{
res+=find(tp|1,mid+1,r,mid+1);//则查3右边
}
}
else
{
res+=find(tp|1,mid+1,r,b);//否则直接递归右边
}
return res;
}
}
}

int main()
{
int t,n,m;
// freopen("shuju.txt","r",stdin);
scanf("%d",&t);
for(int k=1;k<=t;++k)
{
memset(s,0,sizeof(s));
scanf("%s%s%d",s[0]+1,s[1]+1,&m);
n=min(strlen(s[0]+1),strlen(s[1]+1));
build(1,1,n);
printf("Case %d:\n",k);
while(m--)
{
int kase;
scanf("%d",&kase);
if(kase==1)
{
int a,i;char c[2];
scanf("%d%d%s",&a,&i,c);
s[a-1][i+1]=c[0];//修改单点
update(1,1,n,i+1);//更新树
}
else
{
int b;
scanf("%d",&b);
printf("%d\n",find(1,1,n,b+1));//
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: