您的位置:首页 > 其它

hdu 5533 Dancing Stars on Me【计算几何】

2015-12-06 12:54 344 查看

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 580    Accepted Submission(s): 306

[align=left]Problem Description[/align]
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these
moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon.
To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

[align=left]Input[/align]
The first line contains a integer
T
indicating the total number of test cases. Each test case begins with an integer
n,
denoting the number of stars in the sky. Following
n
lines, each contains 2
integers xi,yi,
describe the coordinates of n
stars.

1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000

All coordinates are distinct.
 

[align=left]Output[/align]
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

[align=left]Sample Input[/align]

3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0

 

[align=left]Sample Output[/align]

NO
YES
NO

给出多个点,问是否能构成正多边形

因为给出的都是整数点,所以最多只能构成正方形

判断正方形:

六条组合边,有两条相等,其余四条相等

#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int x[105],y[105];double side[6];
double dis(int i,int j)
{
double s=(y[j]-y[i])*(y[j]-y[i])*1.0+(x[j]-x[i])*(x[j]-x[i])*1.0;
return s;
}
int main()
{
//freopen("shuju.txt","r",stdin);
int t,n;
scanf("%d",&t);
for(int k=1;k<=t;++k)
{
scanf("%d",&n);
for(int i=0;i<n;++i)
{
scanf("%d%d",&x[i],&y[i]);
}
if(n!=4)
{
printf("NO\n");
continue;
}
int cnt=0;
for(int i=0;i<3;++i)
{
for(int j=i+1;j<4;++j)
{
side[cnt++]=dis(i,j);
}
}
sort(side,side+6);
if(side[3]!=side[4]&&(unique(side,side+6)-side)==2)
{
printf("YES\n");
}
else
{
printf("NO\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: