您的位置:首页 > 其它

1050. String Subtraction

2015-11-23 15:31 218 查看


1050. String Subtraction (20)

时间限制

10 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from
S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104.
It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.
Sample Input:
They are students.
aeiou

Sample Output:
Thy r stdnts.

也可以在原有s1字符串基础上,利用erase方法进行删除,但是认为重新开辟一个空间,实现起来给简单通读!

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
using namespace std;

string ans;
string s1;
string s2;
int buf[257];

int main()
{
freopen("F://Temp/input.txt", "r", stdin);
memset(buf, 0, sizeof(buf));
getline(cin, s1);
getline(cin, s2);

for(int i = 0; i < s2.size(); i ++)
buf[s2[i]] = 1;

for(int i = 0; i < s1.size(); i ++)
if(buf[s1[i]] == 0)
ans += s1[i];

cout<<ans<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: