您的位置:首页 > 其它

poj2253Frogger【prim】

2015-11-23 09:30 375 查看
Language:
Default

Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31836 Accepted: 10255
Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her
by jumping. 

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's
stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line
after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


题意:求一只青蛙从给定地点跳到指定地点的所有路径中需要跨过的最大距离的最小距离;

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#define inf 0x3f3f3f3f
using namespace std;
bool vis[210];
double dis[210];
double map[210][210];
struct point{
double x,y;
}A[210];
double dist(point a,point b){
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double prim(int n){
int i,j,pos;
double temp;
memset(vis,false,sizeof(vis));
memset(dis,0x3f,sizeof(dis));
for(i=1;i<=n;++i){
dis[i]=map[1][i];
}dis[1]=0;vis[1]=true;
for(j=1;j<n;++j){
temp=inf;
for(i=1;i<=n;++i){
if(!vis[i]&&temp>dis[i]){
pos=i;temp=dis[i];
}
}
vis[pos]=true;
for(i=1;i<=n;++i){
temp=max(dis[pos],map[pos][i]);
if(!vis[i]&&dis[i]>temp){
dis[i]=temp;
}
}
}
return dis[2];
}
int main()
{
int n,i,j,k=1;
while(scanf("%d",&n),n){
for(i=1;i<=n;++i){
scanf("%lf%lf",&A[i].x,&A[i].y);
for(j=1;j<i;++j){
map[i][j]=map[j][i]=dist(A[i],A[j]);
}
}
printf("Scenario #%d\nFrog Distance = %.3f\n\n",k++,prim(n));
}
return 0;
}

并查集

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int father[210];
struct point{
double x,y;
}A[210];
struct Node{
int s,e;
double d;
}B[50000];
double dist(point a,point b){
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
bool cmp(Node a,Node b){
return a.d<b.d;
}
int find(int x){
int r=x;
while(r!=father[r]){
r=father[r];
}
int i=x,j;
while(i!=r){
j=father[i];
father[i]=r;
i=j;
}
return r;
}
void init(int n){
for(int i=1;i<=n;++i){
father[i]=i;
}
}
int main()
{
int n,i,j,k,t=1;
while(scanf("%d",&n),n){
k=0;
for(i=1;i<=n;++i){
scanf("%lf%lf",&A[i].x,&A[i].y);
for(j=1;j<i;++j){
B[k].s=i;B[k].e=j;B[k++].d=dist(A[i],A[j]);
}
}
sort(B,B+k,cmp);
int flag=0;
for(i=0;i<k;++i){
init(n);
for(j=i;j<k;++j){
int fx=find(B[j].s);
int fy=find(B[j].e);
if(fx!=fy)father[fx]=fy;
if(find(1)==find(2))break;
}
if(j<k)break;
}
printf("Scenario #%d\nFrog Distance = %.3f\n\n", t++, B[j].d);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj2253Froggerprim