您的位置:首页 > 其它

POJ 1125-Stockbroker Grapevine(floyd)

2015-11-22 15:18 274 查看
E - Stockbroker Grapevine
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
1125

Appoint description: 
System Crawler  (2015-11-18)

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours
in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass
the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community.
This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are,
and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring
to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of
stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the
message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0


Sample Output

3 2
3 10


思路:

这题一开始就知道是使用floyd来做了,因为才最大才100,这题就是求一个点到其它点的传播的最快,而且要点到点最小。


AC代码:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<cmath>
typedef long long ll;
using namespace std;
#define T 555
#define inf 0x3f3f3f3f
struct node
{
int from,to,t;
}p[T];
int main()
{
#ifdef zsc
freopen("input.txt","r",stdin);
#endif

int n,m,i,j,k;
int dist[T],ans;
while(~scanf("%d",&n),n)
{
ans=1;
for(j=1;j<=n;++j)
{
scanf("%d",&m);
for(i=1;i<=m;++i,++ans){
p[ans].from = j;
scanf("%d%d",&p[ans].to,&p[ans].t);
}
}
bool flag=true;
int c,ma=inf,num,mm;
for(k=1;k<=n;++k){
for(i=1;i<=n;++i){
dist[i] = inf;
}dist[k] = 0;
for(i=1;i<=n;++i){
for(j=1;j<ans;++j){
if(dist[p[j].to]>dist[p[j].from]+p[j].t){
dist[p[j].to] = dist[p[j].from]+p[j].t;
}
}
}
mm=0;
for(j=1,c=0;j<=n;++j){
if(j!=k&&dist[j]!=inf){
c++;
mm = max(mm,dist[j]);
}
}
if(c==n-1){
flag=false;
if(ma>mm){
ma =mm;num = k;
}
}
}
if(flag){
printf("disjoint\n");
continue;
}
printf("%d %d\n",num,ma);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj floyd