您的位置:首页 > 其它

1035 Password

2015-11-19 20:14 190 查看
To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution
is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order
as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:
1
team110 abcdefg332

Sample Output 2:
There is 1 account and no account is modified

Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:
There are 2 accounts and no account is modified

#include<iostream>
#include<vector>
#include<string>
using namespace std;
struct user{
string name,pwd;
};
int main(){
for(int n;cin>>n;){
vector<user>vec(n);
vector<user>res;
for(int i = 0;i < n;i++){
cin>>vec[i].name>>vec[i].pwd;
}
for(int i = 0;i < n;i++){
int flag = 0;
for(int j =0; j < vec[i].pwd.length();j++){
switch ((vec[i].pwd)[j])
{
case '1':
(vec[i].pwd)[j] = '@';
flag = 1;
break;
case '0':
(vec[i].pwd)[j] = '%';
flag = 1;
break;
case 'l':
(vec[i].pwd)[j] = 'L';
flag = 1;
break;
case 'O':
(vec[i].pwd)[j] = 'o';
flag = 1;
break;
default:
break;
}
}
if(flag){
res.push_back(vec[i]);
}
}
if(res.size()){
cout<<res.size()<<endl;
for(int i = 0; i < res.size();i++){
cout<<res[i].name<<" "<<res[i].pwd<<endl;
}
}else{
if(n == 1){
cout<<"There is 1 account and no account is modified"<<endl;
}else{
cout<<"There are "<<n<<" accounts and no account is modified"<<endl;
}
}
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: