您的位置:首页 > 其它

HDOJ 3466 Proud Merchants 【0 1背包】

2015-11-15 16:34 288 查看

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 3859 Accepted Submission(s): 1615

[align=left]Problem Description[/align]
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any
more.

The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.

If he had M units of money, what’s the maximum value iSea could get?

[align=left]Input[/align]
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.

Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

[align=left]Output[/align]
For each test case, output one integer, indicating maximum value iSea could get.

[align=left]Sample Input[/align]

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3


[align=left]Sample Output[/align]

5
11


题目链接:HDOJ 3466 Proud Merchants 【0 1背包】

题意:首先给出物品数量和手中资金人后每样物品给出价格,需要购买时手中至少需要多少资金,还有物品本身的价值要求求出最大资金

思路:0 1 背包,要注意的是要先按 q-p 排序(使差值最小)

已AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define Max(x,y) (x>y?x:y)
#define M 6000
using namespace std;

struct node{
int p,q,v;
}s[M];
int dp[M],n,m;

bool cmp(node a,node b)
{
return a.q-a.p < b.q-b.p;
}
int main()
{
int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=0;i<n;++i)
scanf("%d%d%d",&s[i].p,&s[i].q,&s[i].v);

sort(s,s+n,cmp);

memset(dp,0,sizeof(dp));

for(i=0;i<n;++i)
for(j=m;j>=s[i].q;--j)
dp[j]=Max(dp[j],dp[j-s[i].p]+s[i].v);

printf("%d\n",dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: