您的位置:首页 > 其它

poj 2250 Compromise(LCS)

2015-11-12 22:26 337 查看
Compromise

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7346Accepted: 3235Special Judge
Description

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the
criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.

Therefore the German government requires a program for the following task:

Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what
both people have in mind).

Your country needs this program, so your job is to write it for us.
Input

The input will contain several test cases.

Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a
line containing a single '#'.

Input is terminated by end of file.
Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.
Sample Input
die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output
die einkommen der abgeordneten muessen dringend verbessert werden


给出两段文字,求出最长的公共单词串

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
char a[35][105],b[35][105],ans[35][105];
int dp[105][105],vis[105][105],len1,len2;
int cnt;

void lcs()
{
memset(dp, 0, sizeof(dp));
memset(vis, 0, sizeof(vis));

for (int i=0; i<=len1; i++)
vis[i][0]=1;
for (int i=0; i<=len2; i++)
vis[0][i]=-1;

int flag;
for (int i=1; i<=len1; i++)
{
for (int j=1; j<=len2; j++)
{
flag=strcmp(a[i-1],b[j-1]);
if(!flag)
{
dp[i][j]=dp[i-1][j-1]+1;
vis[i][j]=0;
}
else if(dp[i-1][j]>=dp[i][j-1])
{
dp[i][j]=dp[i-1][j];
vis[i][j]=1;
}
else
{
dp[i][j]=dp[i][j-1];
vis[i][j]=-1;
}
}
}
}

void print(int i,int j)
{
if(!i && !j)
return;
if (vis[i][j]==0)
{
print(i-1, j-1);
strcpy(ans[cnt++], a[i-1]);
}
else if(vis[i][j]==1)
print(i-1, j);
else
print(i, j-1);
}

int main()
{

while (scanf("%s",a[0])!=EOF)
{
len1=1;
while (strcmp(a[len1-1], "#"))
scanf("%s",a[len1++]);

len1-=1;
scanf("%s",b[0]);
len2 = 1;
while(strcmp(b[len2-1],"#"))
scanf("%s",b[len2++]);
len2-=1;
lcs();
cnt=0;
print(len1, len2);
printf("%s",ans[0]);
for(int i = 1; i<cnt; i++)
printf(" %s",ans[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: