您的位置:首页 > 其它

Above Average

2015-11-11 10:53 351 查看


Above Average



Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^


题目描述

It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.

输入

The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by
spaces or newlines, each giving the final grade (an integer between 0 and 100) of a student in the class.

输出

For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.

示例输入

5
5 50 50 70 80 100
7 100 95 90 80 70 60 50
3 70 90 80
3 70 90 81
9 100 99 98 97 96 95 94 93 91


示例输出

40.000%
57.143%
33.333%
66.667%
55.556%


提示

来源

面向对数据结构和算法不太了解的同学

示例程序

#include <stdio.h>
int main()
{
int i,j,n,m,d;
double a[1000],b,c;
scanf("%d",&n);
for(i=0;i<n;i++)
{
b=0;
d=0;
scanf("%d",&m);
for(j=0;j<m;j++)
{
scanf("%lf",&a[j]);
b+=a[j];
}
c=1.0*b/m;

for(j=0;j<m;j++)
{
if(a[j]>c)
d++;
}
printf("%.3lf%%\n",1.0*d*100/m);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: