您的位置:首页 > 其它

Geometry Made Simple

2015-11-11 10:50 218 查看


Geometry Made Simple



Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^


题目描述

Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse)
satisfy the relation a*a+b*b=c*c. This is called Pythagora's Law.

Here we consider the problem of computing the length of the third side, if two are given.



输入

The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three
numbers is equal to -1 (the 'unknown' side), the others are positive (the 'given' sides).

A description having a=b=c=0 terminates the input.

输出

For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print "Impossible." if there is no right-angled triangle, that has the 'given' side lengths. Otherwise output
the length of the 'unknown' side in the format "s = l", where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.

Print a blank line after each test case.

示例输入

3 4 -1
-1 2 7
5 -1 3
0 0 0


示例输出

Triangle #1
c = 5.000

Triangle #2
a = 6.708

Triangle #3
Impossible.


提示

来源

面向对数据结构和算法不太懂的同学

示例程序

#include <stdio.h>
#include<math.h>
int main()
{
double a,b,c,d;
int k=0;
while(scanf("%lf%lf%lf",&a,&b,&c),(a||b||c))
{
k++;
if(a==-1)
{
d=sqrt(c*c-b*b);
if(d>c-b&&d<c+b)
printf("Triangle #%d\na = %.3lf\n\n",k,d);
else
printf("Triangle #%d\nImpossible.\n\n",k);
}
if(b==-1)
{
d=sqrt(c*c-a*a);
if(d>c-a&&d<c+a)
printf("Triangle #%d\nb = %.3lf\n\n",k,d);
else
printf("Triangle #%d\nImpossible.\n\n",k);
}
if(c==-1)
{
d=sqrt(a*a+b*b);
if(d>fabs(b-a)&&d<a+b)
printf("Triangle #%d\nc = %.3lf\n\n",k,d);
else
printf("Triangle #%d\nImpossible.\n\n",k);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: