您的位置:首页 > 大数据 > 人工智能

HDU 1022 Train Problem I

2015-11-10 15:55 519 查看
Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.







 

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.

 

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

 

Sample Input

3 123 321
3 123 312

 

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

 

UVa 514 升级版,如果可以,输出路径。
加一个路径数组记录路径就好了,-1 代表未访问,0 代表 out ,1 代表 in 。

#include <iostream>
#include <stack>
#include <cstring>
using namespace std;

int main(int argc, char const *argv[])
{
int N;
string A,B;
while(cin >> N)
{
cin >> A >> B;

int a = 0,b = 0,flag = 1,i = 0;
int path[25];
memset(path,-1,sizeof(path));
stack<char> s;

while(b < N)
{
if(A[a] == B[b])
{
a++,b++;
path[i++] = 1,path[i++] = 0;
}
else if(!s.empty() && s.top() == B[b])
{
s.pop();
path[i++] = 0;
b++;
}
else if(a < N)
{
s.push(A[a++]);
path[i++] = 1;
}
else
{
flag = 0;
break;
}
}

if(flag)
{
cout << "Yes." << endl;
for(int j = 0;j < i;j++)
{
if(path[j] == 1)
cout << "in" << endl;
else if(path[j] == 0)
cout << "out" << endl;
}
}
else
cout << "No." << endl;
cout << "FINISH" << endl;
}
return 0;
}


Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.







 

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.

 

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

 

Sample Input

3 123 321
3 123 312

 

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU 数据结构