您的位置:首页 > 产品设计 > UI/UE

hdoj House Building 5538 (数学几何&&搜索)

2015-11-05 13:38 465 查看

House Building

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 151    Accepted Submission(s): 129


[align=left]Problem Description[/align]
Have you ever played the video game Minecraft? This game has been one of the world's most popular game in recent years. The world of Minecraft is made up of lots of
1×1×1
blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ... or even a building material such as brick or concrete in this game.



Figure 1: A typical world in Minecraft.

Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it's really a lovely place to build
houses on it. Nyanko-san decided to build on a n×m
big flat ground, so he drew a blueprint of his house, and found some building materials to build.

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your
job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.

There are n
rows and m
columns on the ground, an intersection of a row and a column is a
1×1
square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san's blueprint can be represented as an integer array
ci,j(1≤i≤n,1≤j≤m).
Which ci,j
indicates the height of his house on the square of
i-th
row and j-th
column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san's house(exclude the face adjacent to the ground).

 

[align=left]Input[/align]
The first line contains an integer
T
indicating the total number of test cases.

First line of each test case is a line with two integers
n,m.

The n
lines that follow describe the array of Nyanko-san's blueprint, the
i-th
of these lines has m
integers ci,1,ci,2,...,ci,m,
separated by a single space.

1≤T≤50
1≤n,m≤50
0≤ci,j≤1000

 

[align=left]Output[/align]
For each test case, please output the number of glass units you need to collect to meet Nyanko-san's requirement in one line.

 

[align=left]Sample Input[/align]

2
3 3
1 0 0
3 1 2
1 1 0
3 3
1 0 1
0 0 0
1 0 1

 

[align=left]Sample Output[/align]

30
20



Figure 2: A top view and side view image for sample test case 1.

 

[align=left]Source[/align]
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define N 110
using namespace std;
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
int h

;
int main()
{
int t,n,m,i,j,k;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
memset(h,0,sizeof(h));
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
scanf("%d",&h[i][j]);
}
}
int ans=0;
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
if(h[i][j])
ans++;
for(k=0;k<4;k++)
{
int nx=i+dx[k];
int ny=j+dy[k];
int q=h[i][j]-h[nx][ny];
if(q>0)
ans+=q;
}
}
}
printf("%d\n",ans);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: