您的位置:首页 > 编程语言 > Go语言

hdoj Ancient Go 5546 (搜索) 好题

2015-11-05 22:24 495 查看

Ancient Go

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)

Total Submission(s): 99    Accepted Submission(s): 54


[align=left]Problem Description[/align]
Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

⋅The
game is played on a 8×8
cell board, the chess can be put on the intersection of the board lines, so there are
9×9
different positions to put the chess.
⋅Yu
Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
⋅The
chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
⋅When
one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.

One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's
chess.

[align=left]Input[/align]
The first line of the input gives the number of test cases,
T(1≤T≤100).
T
test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board.
′.′
represents an empty cell. ′x′
represents a cell with black chess which owned by Yu Zhou.
′o′
represents a cell with white chess which owned by Su Lu.

[align=left]Output[/align]
For each test case, output one line containing
Case #x: y
, where x
is the test case number (starting from 1) and y
is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components.
Can not kill in one move!!! otherwise.

[align=left]Sample Input[/align]

2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o

[align=left]Sample Output[/align]

Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!
Hint
In the first test case, Yu Zhou has 4 different ways to kill Su Lu's component.

In the second test case, there is no way to kill Su Lu's component.
题意:一个9*9的棋盘,判断能否把接下来的一个x,放到地图中的一个空白位置上。 使得出现一个‘o’或者一片‘o’被堵死。思路:遍历每一个‘o’或一片‘o’周边的空白位置,看是否‘o’的周围可放的位置只有一个。若是,则符合题意,否则,不符合题意。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
char map[10][10];
int v[10][10];
int vv[10][10];
int cnt;
void dfs(int x,int y)
{
for(int i=0;i<4;i++)//这块判断只有一个‘o’时的情况
{
int nx=x+dx[i];
int ny=y+dy[i];
if(nx>=0&&nx<9&&ny>=0&&ny<9&&map[nx][ny]=='.'&&!vv[nx][ny])
{
vv[nx][ny]=1;
cnt++;
}
}
for(int i=0;i<4;i++)//这个用来判断有多个‘o’时的情况
{
int nx=x+dx[i];
int ny=y+dy[i];
if(nx>=0&&nx<9&&ny>=0&&ny<9&&map[nx][ny]=='o'&&!v[nx][ny])
{
v[nx][ny]=1;
dfs(nx,ny);
}
}
}
int main()
{
int t,n,i,j;
int T=1;
scanf("%d",&t);
while(t--)
{
for(i=0;i<9;i++)
scanf("%s",map[i]);
int flag=0;
memset(v,0,sizeof(v));
for(i=0;i<9;i++)
{
for(j=0;j<9;j++)
{
if(map[i][j]=='o'&&!v[i][j])//逐个遍历‘o’旁边的情况
{
memset(vv,0,sizeof(vv));
cnt=0;
v[i][j]=1;
dfs(i,j);
if(cnt==1)
{
flag=1;
break;
}
}
}
if(flag)
break;
}
if(flag)
printf("Case #%d: Can kill in one move!!!\n",T++);
else
printf("Case #%d: Can not kill in one move!!!\n",T++);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: