您的位置:首页 > 其它

poj 1305

2015-11-04 22:42 183 查看
Fermat vs. Pythagoras

Time Limit: 2000MSMemory Limit: 10000K
Total Submissions: 1450Accepted: 846
Description

Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and current efforts in verification have succeeded in verifying the translation of high-level code down to the chip level.
This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of a^n + b^n = c^n for n > 2.
Given a positive integer N, you are to write a program that computes two quantities regarding the solution of x^2 + y^2 = z^2, where x, y, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x < y < z, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values 0 < p <= N such that p is not part of any triple (not just relatively prime triples).
Input

The input consists of a sequence of positive integers, one per line. Each integer in the input file will be less than or equal to 1,000,000. Input is terminated by end-of-file
Output

For each integer N in the input file print two integers separated by a space. The first integer is the number of relatively prime triples (such that each component of the triple is <=N). The second number is the number of positive integers <=N that are not part of any triple whose components are all <=N. There should be one output line for each input line.
Sample Input

10
25
100

Sample Output

1 4
4 9
16 27

Source

Duke Internet Programming Contest 1991,UVA 106
暴力枚举就好

#include <cstdio>
#include <cstring>
#include <iostream>
#include <stack>
#include <queue>
#include <map>
#include <algorithm>
#include <vector>
#include <cmath>

using namespace std;

const int maxn = 1000001;

typedef long long LL;

bool flag[maxn];

int gcd(int a,int b)
{
if(b == 0) return a;
else return gcd(b,a%b);
}
void solve(int t)
{
int temp,m,i,j,k,n,ans1,ans2,x,y,z;
memset(flag,0,sizeof(flag));
temp = sqrt(t+0.0);
ans1 = ans2 = 0;
for( i=1;i<=temp;i++){
for(j = i+1;j<=temp;j++){
if(i*i + j*j > t) break;
if((i%2) != (j%2)){
if(gcd(i,j) == 1){
x = j*j - i*i;
y = 2*i*j;
z = j*j + i*i;
ans1++;
for( k=1;;k++){
if( k*z > t) break;
flag[k*x] = 1;
flag[k*y] = 1;
flag[k*z] = 1;
}
}
}
}
}
for(int i=1;i<=t;i++){
if(!flag[i]) ans2++;
}
printf("%d %d\n",ans1,ans2);
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF){
solve(n);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: