您的位置:首页 > 其它

HDU 1079 Calendar Game

2015-11-01 22:16 471 查看

Calendar Game

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3291 Accepted Submission(s): 1935

[align=left]Problem Description[/align]
Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001,
the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current
date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either
to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years
ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent
the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.

[align=left]Output[/align]
Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines
of "YES" or "NO".

[align=left]Sample Input[/align]

3
2001 11 3
2001 11 2
2001 10 3

[align=left]Sample Output[/align]

YES
NO
NO

分析:无论增加一月或是一天,都会改变原来月数跟天数之和的奇偶性(9月30号和11月30号在天数加一时不满足)。

策略:目标日期为11月4号之和15为奇数;因此若初始日期之和为偶数的话(9月30号和11月30号为奇数但也满足),先手必胜,反之后手必胜。(至于9月30号和11月30号这两天,若初始日期为这两天,先手第一轮只需让天数加一(变为10.1和12.1,和为奇数),下一轮开始日期和必为偶数,在接下来的轮次中,先手(若不傻的话)必定会避开这两天,那么先手必胜。)

代码:
#include <stdio.h>
int main(void)
{int n,y,m,d;
scanf("%d",&n);
while(n--)
{scanf("%d%d%d",&y,&m,&d);
if(0==(m+d)%2||((9==m||11==m)&&30==d))
puts("YES");
else puts("NO");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 博弈