您的位置:首页 > 其它

杭电1114--完全背包

2015-11-01 12:27 441 查看
Piggy-Bank


Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input

3

10 110

2

1 1

30 50

10 110

2

1 1

50 30

1 6

2

10 3

20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.

The minimum amount of money in the piggy-bank is 100.

This is impossible.

# include <iostream>
# include <cstdio>
# include <algorithm>
# include <cstring>
using namespace std;

/*
就是有一个存钱罐,比不知道里面有多少钱,但是我们知道(就是 输入)T组测试数据
E 空的存钱罐的质量, F 存钱罐装满钱的重量,
接着输入   N   里面硬币的种类,下面N行
P  硬币的价值, W 硬币的质量
你的任务是求出来存钱罐里面最少多少钱 样例1:
10 110
2
1 1
30 50
里面的硬币是 2个价值30,重量为50的硬币的时候,最少,故宗价值最少60.

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

*/

int f[10000];
int main(){

int T,n,m;

//本题:把硬币的价值看作w,硬币的质量看作c

int w[509]; // 硬币的价值
int c[509]; //硬币的质量
int i,j,k;
int ew,fw,cw;//空的质量,与满的重量,净重量

scanf("%d",&T);
while(T--){

scanf("%d%d",&ew,&fw);
cw = fw - ew;
scanf("%d",&n);
for(i=0;i<n;i++){
scanf("%d%d",&w[i],&c[i]);
}

for(i=0;i<=cw;i++){
f[i] = 1000000001;
}
f[0] = 0;

for(i=0;i<n;i++){//物品数

for(j=c[i];j<=cw;j++){
if(f[j]>f[j-c[i]]+w[i]){
f[j] = f[j-c[i]]+w[i];
//  printf("%d   ",f[j]);
}
}

//  printf("\n");

}

if(f[cw]==1000000001){
printf("This is impossible.\n");
}else{
printf("The minimum amount of money in the piggy-bank is %d.\n",f[cw]);
}

}

return 0;
}


代码2:

#include<stdio.h>
int num[10001],w[500],v[500];
main()
{
int n,m,e,f,t,i,j;
for(scanf("%d",&t);t>0;t--)
{
scanf("%d%d",&e,&f);
m=f-e;
for(scanf("%d",&n),i=0;i<n;i++)
scanf("%d%d",&v[i],&w[i]);
num[0]=0;
for(i=1;i<=m;i++)
num[i]=-1;
for(i=0;i<n;i++)
{
for(j=w[i];j<=m;j++)
{
if(num[j-w[i]]!=-1&&num[j]!=-1)
{if(num[j-w[i]]+v[i]<num[j]) num[j]=num[j-w[i]]+v[i];}
else if(num[j-w[i]]!=-1&&num[j]==-1)
{num[j]=num[j-w[i]]+v[i];}
}
}
if(num[m]!=-1)
printf("The minimum amount of money in the piggy-bank is %d.\n",num[m]);
else
printf("This is impossible.\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: