您的位置:首页 > 其它

uva532Dungeon Master

2015-10-31 19:03 106 查看
Description



You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and
the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input Specification

The input file consists of a number of dungeons. Each dungeon description starts with a line containing three integersL,
R and C (all limited to 30 in size).

L is the number of levels making up the dungeon.

R and C are the number of rows and columns making up the plan of each level.

Then there will follow L blocks of R lines each containing
C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a `#' and empty cells are represented by a `.'. Your starting position is indicated by `S' and the exit by the letter 'E'.
There's a single blank line after each level. Input is terminated by three zeroes forL,
R and C.

Output Specification

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.

If it is not possible to escape, print the line

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

三维bfs
不难但是一直犯傻
先是RE
又是wa
30*30*30
list数组我一开始开太小了

#include <stdio.h>
#include <string.h>
#define N 30010

char map[40][40][40];
int flag[40][40][40], list
[4];
int step[6][4] = {{0, 1, 0}, {0, -1, 0}, {0, 0, 1}, {0, 0, -1}, {1, 0, 0}, {-1, 0, 0}};
int l, r, c, cnt
;

int bfs(int l1, int r1, int c1, int l2, int r2, int c2){
if (l1 == l2 && r1 == r2 && c1 == c2)
return 0;
int head = 0, nail = 1;
cnt[head] = 0;
list[head][0] = l1, list[head][1] = r1, list[head][2] = c1;
while (head < nail) {
for (int i = 0; i < 6; i++) {
int x = step[i][0] + list[head][0];
int y = step[i][1] + list[head][1];
int z = step[i][2] + list[head][2];
if (x >= 0 && x < l && y >= 0 && y < r && z >= 0 && z < c && !flag[x][y][z]) {
if (x == l2 && y == r2 && z == c2)
return cnt[head] + 1;
if (map[x][y][z] == '.') {
list[nail][0] = x;
list[nail][1] = y;
list[nail][2] = z;
cnt[nail++] = cnt[head] + 1;
flag[x][y][z] = 1;
}
}
}
head++;
}
return 0;
}

int main(){
int l1, r1, c1, l2, r2, c2;
char s;
while (scanf("%d%d%d", &l, &r, &c) != EOF) {
if (!l && !r && !c)
break;
memset(flag, 0, sizeof(flag));
memset(list, 0, sizeof(list));
memset(cnt, 0, sizeof(cnt));

for (int i = 0; i < l; i++) {
for (int j = 0; j < r; j++) {
getchar();
for (int k = 0; k < c; k++)
scanf("%c", &map[i][j][k]);
}
getchar();
}

for (int i = 0; i < l; i++)
for (int j = 0; j < r; j++)
for (int k = 0; k < c; k++) {
if (map[i][j][k] == 'S')
l1 = i, r1 = j, c1 = k;
if (map[i][j][k] == 'E')
l2 = i, r2 = j, c2 = k;
}

int count = bfs(l1, r1, c1, l2, r2, c2);
if (count)
printf("Escaped in %d minute(s).\n", count);
else
printf("Trapped!\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: