您的位置:首页 > 产品设计 > UI/UE

Number Sequence

2015-10-30 08:50 459 查看
Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

1 1 3
1 2 10
0 0 0

 

Sample Output

2
5

 

#include<iostream>
#include<cstdio>
using namespace std;
int main(){
int f[50];
int a,b,i,n,num;
while(cin >> a >> b >> n){
if(a==0 && b==0 && n==0) break;
f[1]=1;f[2]=1;
for(i=3;i<50;i++){
f[i]=(a*f[i-1]+b*f[i-2])%7;
if(f[i]==1 && f[i-1]==1)
break;
}
num=i;
num=num-2;
n=n%num;
if(n==0)
printf("%d\n",f[num]);
else
printf("%d\n",f
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  递归