您的位置:首页 > 其它

杭电ACM-HDU1004-Let the Balloon Rise

2015-10-29 15:15 337 查看
题目来自杭电ACM: acm.hdu.edu.cn

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 93510 Accepted Submission(s): 35712

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color
and find the result.

This year, they decide to leave this lovely job to you.



Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case
letters.

A test case with N = 0 terminates the input and this test case is not to be processed.



Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.



Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0




Sample Output
red
pink




Author
WU, Jiazhi


Source
ZJCPC2004

代码如下:

#include <stdio.h>
#include <string.h>
#define N 1010
int count
;
char ballon
[16];
int main()
{
	int n, i, j;
	while (1){
		scanf("%d", &n);
		if (n == 0){
			break;
		}
		gets(ballon[0]);
		for (i = 1; i <= n; ++i){
			gets(ballon[i]);
		}
		int max = 1, position = 1;
		for (i = 1; i <= n; ++i){
			count[i] = 0;
			for (j = i; j <= n; ++j){
				if (strcmp(ballon[i], ballon[j]) == 0){
					count[i]++;
					if (count[i] > max){
						max = count[i];
						position = i;
					}
				}
			}
		}
		printf("%s\n", ballon[position]);
	}
	return 0;
}


这是一个较为简单的考察字符串的题目,通过头文件string.h中的strcmp函数来判断字符串是否相同。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: