您的位置:首页 > 大数据 > 人工智能

栈对于表达式求值的特殊作用&&UVa442 Matrix Chain Multiplication(矩阵链乘)的理解与解析

2015-10-29 11:50 543 查看
栈对于表达式求值的特殊作用&&UVa442 Matrix Chain Multiplication(矩阵链乘)的理解与解析

栈对于表达式求值的特殊作用,简单的表达式解析可以借助栈来完成。



 Matrix Chain Multiplication 
Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the
number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n ( 

 ), representing
the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"


Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print
one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))


Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125



Solution

解决方法来自书上,这里根据自己的理解加了注释

#include <iostream>
#include <stack>
#include <string>
#include <cstdio>
using namespace std;

class Matrix{
public:
Matrix(int a=0,int b=0):a(a),b(b) {}
int a,b;
} m[26];

stack<Matrix> s;

int main()
{
int n;
cin>>n;
for(int i=0;i<n;i++){
string name;
cin>>name;
int k=name[0]-'A';    //化字母为数字进行储存和处理
cin>>m[k].a>>m[k].b;
}
string expr;
while(cin>>expr){
int len=expr.length();    // 这里length()和size()的区别
bool error=false;         //用来返回程序执行情况
int ans=0;
for(int i=0;i<len;i++){
if(isalpha(expr[i])) s.push(m[expr[i]-'A']);
else if(expr[i]=')'){
Matrix m2=s.top(); s.pop();   //后入先出
Matrix m1=s.top(); s.pop();   //先入后出
if(m1.b!=m2.a) {error=true;break;}
ans+=m1.a*m1.b*m2.b;
s.push(Matrix(m1.a,m2.b));   //把等到的 新矩阵 重新构造为Matrix对象,并入栈
}
}
if(error) printf("error\n");
else printf("%d\n",ans);
}
return 0;
}


谢谢
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: