您的位置:首页 > 其它

HDU2444(判断是否为二分图,求最大匹配)

2015-10-25 10:25 337 查看

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3836    Accepted Submission(s): 1797

Problem Description There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.   Input For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.   Sample Input 4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6   Sample Output No 3   Source 2008 Asia Harbin Regional Contest Online   题意:给定n个点m条边的无向图,判断是否为二分图,如果不是输出No,是则输出最大匹配。 判断是否为二分图:dfs,如果某个点u没有赋id,则赋为1,找到所有与他相邻的点,如果存在某个点id和该点相同则return false; 如果id==0则赋为-1*id[u]继续dfs; 求最大匹配用匈牙利算法,注意由于原图是个无向图,是自己人工把他当成二分图,所以如果左边的点1和右边的点2之间有边,则右边的点1和左边的点2之间也有边,所有求出的最大匹配要除以2;
/*
ID: LinKArftc
PROG: 2444.cpp
LANG: C++
*/

#include <map>
#include <set>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <utility>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-8
#define randin srand((unsigned int)time(NULL))
#define input freopen("input.txt","r",stdin)
#define debug(s) cout << "s = " << s << endl;
#define outstars cout << "*************" << endl;
const double PI = acos(-1.0);
const double e = exp(1.0);
const int inf = 0x3f3f3f3f;
const int INF = 0x7fffffff;
typedef long long ll;

const int maxn = 510;
const int maxm = 250010;

int mp[maxn][maxn];
int linker[maxn];
int id[maxn];
int uN, vN;
int n, m;
bool vis[maxn];

bool dfs(int x) {
for (int i = 1; i <= n; i ++) {
if (mp[x][i]) {
if (id[i] == id[x]) return false;
if (id[i] == 0) {
id[i] = -1 * id[x];
if (!dfs(i)) return false;
}
}
}
return true;
}

bool dfs1(int u) {
for (int v = 1; v <= n; v ++) {
if (mp[u][v] && !vis[v]) {
vis[v] = true;
if (linker[v] == -1 || dfs1(linker[v])) {//刚开始这地方写成dfs了,罪过呀,写的有点混乱,下次注意!
linker[v] = u;
return true;
}
}
}
return false;
}

int hungry() {
memset(linker, -1, sizeof(linker));
int ret = 0;
for (int i = 1; i <= n; i ++) {
memset(vis, 0, sizeof(vis));
if (dfs1(i)) ret ++;
}
return ret;
}

int main() {
//input;
int u, v;
while (~scanf("%d %d", &n, &m)) {
memset(mp, 0, sizeof(mp));
memset(id, 0, sizeof(id));
for (int i = 1; i <= m; i ++) {
scanf("%d %d", &u, &v);
mp[u][v] = 1;
mp[v][u] = 1;
}
bool flag = true;
for (int i = 1; i <= n; i ++) {
if (!id[i]) {
id[i] = 1;
if (!dfs(i)) {
flag = false;
break;
}
}
}
if (!flag) {
printf("No\n");
continue;
} else printf("%d\n", hungry() / 2);
}
return 0;
}

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: