您的位置:首页 > 其它

HDU1142 (Dijkstra+记忆化搜索)

2015-10-23 15:33 288 查看

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6935    Accepted Submission(s): 2548

Problem Description Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.    Input Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.    Output For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647   Sample Input 5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0   Sample Output 2 4   Source University of Waterloo Local Contest 2005.09.24   题意是求从起点1到终点2的满足条件的路径条数,条件是该条路径上的所有边AB都要满足A到终点的最短路大于B到终点的最短路。 思路就是Dijkstra+记忆化搜索  
/*
ID: LinKArftc
PROG: 1142.cpp
LANG: C++
*/

#include <map>
#include <set>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <utility>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-8
#define randin srand((unsigned int)time(NULL))
#define input freopen("input.txt","r",stdin)
#define debug(s) cout << "s = " << s << endl;
#define outstars cout << "*************" << endl;
const double PI = acos(-1.0);
const double e = exp(1.0);
const int inf = 0x3f3f3f3f;
const int INF = 0x7fffffff;
typedef long long ll;

const int maxn = 1010;
int n, m;
int mp[maxn][maxn];
int dis[maxn];
bool vis[maxn];

void dij(int s) {
for (int i = 1; i <= n; i ++) dis[i] = mp[s][i];
memset(vis, 0, sizeof(vis));
vis[s] = true;
dis[s] = 0;
for (int i = 2; i <= n; i ++) {
int mi = inf;
int ii = s;//要赋值,因为下一行的for循环可能并不改变ii的值,所以可能会RE
for (int j = 1; j <= n; j ++) {
if (!vis[j] && dis[j] < mi) {
mi = dis[j];
ii = j;
}
}
vis[ii] = true;
for (int j = 1; j <= n; j ++) {
if (!vis[j] && dis[j] > dis[ii] + mp[ii][j]) {
dis[j] = dis[ii] + mp[ii][j];
}
}
}
}

int cnt[maxn];

int dfs(int cur) {
if (cnt[cur]) return cnt[cur];
if (cur == 2) return 1;
int ret = 0;
for (int i = 1; i <= n; i ++) {
if (mp[cur][i] == inf || dis[i] >= dis[cur]) continue;
ret += dfs(i);
}
cnt[cur] = ret;
return ret;
}

int main() {
//input;
int u, v, c;
while (~scanf("%d", &n) && n) {
scanf("%d", &m);
memset(mp, 0x3f, sizeof(mp));
for (int i = 1; i <= m; i ++) {
scanf("%d %d %d", &u, &v, &c);
mp[u][v] = c;
mp[v][u] = c;
}
dij(2);
//for (int i = 1; i <= n; i ++) printf("dis[%d] = %d\n", i, dis[i]);
memset(cnt, 0, sizeof(cnt));
printf("%d\n", dfs(1));
}

return 0;
}

 

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: