您的位置:首页 > 其它

Attack(树状数组)

2015-10-18 12:54 363 查看
http://acm.hdu.edu.cn/showproblem.php?pid=4031


Attack

Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 2243 Accepted Submission(s): 667



Problem Description

Today is the 10th Annual of “September 11 attacks”, the Al Qaeda is about to attack American again. However, American is protected by a high wall this time, which can be treating as a segment with length N. Al Qaeda has a super weapon, every second it can attack
a continuous range of the wall. American deployed N energy shield. Each one defends one unit length of the wall. However, after the shield defends one attack, it needs t seconds to cool down. If the shield defends an attack at kth second, it can’t defend any
attack between (k+1)th second and (k+t-1)th second, inclusive. The shield will defend automatically when it is under attack if it is ready.

During the war, it is very important to understand the situation of both self and the enemy. So the commanders of American want to know how much time some part of the wall is successfully attacked. Successfully attacked means that the attack is not defended
by the shield.

Input

The beginning of the data is an integer T (T ≤ 20), the number of test case.

The first line of each test case is three integers, N, Q, t, the length of the wall, the number of attacks and queries, and the time each shield needs to cool down.

The next Q lines each describe one attack or one query. It may be one of the following formats

1. Attack si ti

Al Qaeda attack the wall from si to ti, inclusive. 1 ≤ si ≤ ti ≤ N

2. Query p

How many times the pth unit have been successfully attacked. 1 ≤ p ≤ N

The kth attack happened at the kth second. Queries don’t take time.

1 ≤ N, Q ≤ 20000

1 ≤ t ≤ 50

Output

For the ith case, output one line “Case i: ” at first. Then for each query, output one line containing one integer, the number of time the pth unit was successfully attacked when asked.

Sample Input

2
3 7 2
Attack 1 2
Query 2
Attack 2 3
Query 2
Attack 1 3
Query 1
Query 3
9 7 3
Attack 5 5
Attack 4 6
Attack 3 7
Attack 2 8
Attack 1 9
Query 5
Query 3


Sample Output

Case 1:
0
1
0
1
Case 2:
3
2


未能成功防守的次数等于总共被攻击的次数减去防守成功的次数,在一个防守成功后的t秒内都不能成功防守,
#include <cstdio>
#include <cstring>
int n,q,t;
int d[20010];
int pos[20010];
int defen[20010];
int l[20010],r[20010];
int bit(int t){
return t&(-t);
}
int getsum(int pos){
int ans=0;
while(pos>0){
ans+=d[pos];
pos-=bit(pos);
}
return ans;
}
void update(int pos,int num){
while(pos<=n){
d[pos]+=num;
pos+=bit(pos);
}
}
int main(){
//freopen("F://in.txt","w",stdout);
int T;
scanf("%d",&T);
for(int Case=1;Case<=T;Case++){
memset(d,0,sizeof(d));
memset(pos,0,sizeof(pos));
memset(defen,0,sizeof(defen));
scanf("%d%d%d",&n,&q,&t);
printf("Case %d:\n",Case);
char s[10];
int p;
int cnt=0;
while(q--){
scanf("%s",s);
if(s[0]=='A'){
scanf("%d%d",&l[cnt],&r[cnt]);
update(l[cnt],1);
update(r[cnt]+1,-1);
cnt++;
}
else {
scanf("%d",&p);
for(int i=pos[p];i<cnt;i++)
{
if(p>=l[i]&&p<=r[i]){
pos[p]=t+i;
defen[p]++;
i+=t-1;
}
}
printf("%d\n",getsum(p)-defen[p]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: