您的位置:首页 > 其它

Max Sum(dp水题)

2015-10-19 21:45 218 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1003

还是子序列求和


Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 186386 Accepted Submission(s): 43487



Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output

Case 1:
14 1 4

Case 2:
7 1 6


#include <cstdio>
int main(){
int t;
scanf("%d",&t);
for(int Case=1;Case<=t;Case++){
int a,max_sum=-1001,max_first,max_last,tot=-1,last,first;
int d;
scanf("%d",&d);
for(int i=1;i<=d;i++){
scanf("%d",&a);
if(tot<0){
first=last=i;
tot=a;
}
else {
tot+=a;last=i;
}
if(tot>max_sum){
max_sum=tot;
max_first=first;
max_last=last;
}
}
printf("Case %d:\n%d %d %d\n",Case,max_sum,max_first,max_last);
if(Case!=t)printf("\n");
}
return 0;
}
AC之路,我选择坚持~~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: