您的位置:首页 > 其它

There is a board with

2015-10-13 21:57 375 查看
There is a board with 100 * 100 grids as shown below. The left-top gird is denoted as (1, 1) and the right-bottom grid is (100, 100).

We may apply three commands to the board:

WHITE x, y, L // Paint a white square on the board,

// the square is defined by left-top grid (x, y)

// and right-bottom grid (x+L-1, y+L-1)

BLACK x, y, L // Paint a black square on the board,

// the square is defined by left-top grid (x, y)

// and right-bottom grid (x+L-1, y+L-1)

TEST x, y, L // Ask for the number of black grids

// in the square (x, y)- (x+L-1, y+L-1)

In the beginning, all the grids on the board are white. We apply a series of commands to the board. Your task is to write a program to give the numbers of black grids within a required region when a TEST command is applied.

输入

The first line of the input is an integer t (1 <= t <= 100), representing the number of commands. In each of the following lines, there is a command. Assume all the commands are legal which means that they won’t try to paint/test the grids outside the board.

输出

For each TEST command, print a line with the number of black grids in the required region.

样例输入

5

BLACK 1 1 2

BLACK 2 2 2

TEST 1 1 3

WHITE 2 1 1

TEST 1 1 3

样例输出

7

6

#include<stdio.h>
#include<string.h>
char arr[1050][1000],m;
int brr[1050][40],ans[105]={0,0},num=0,map[1005][1005]={0,0};
void Wasd(int a,int b,int c)
{
int x,y,i,j;
x=a+c-1;
y=b+c-1;
for(i=a;i<=x;i++)
for(j=b;j<=y;j++)
map[i][j]=0;
}
void Basd(int a,int b,int c)
{
int x,y,i,j;
x=a+c-1;
y=b+c-1;
for(i=a;i<=x;i++)
for(j=b;j<=y;j++)
map[i][j]=1;
}
void Tasd(int a,int b,int c)
{
int x,y,i,j;
x=a+c-1;
y=b+c-1;
for(i=a;i<=x;i++)
for(j=b;j<=y;j++)
if(map[i][j]==1)
{
ans[num]++;
}
num++;
}
int main()
{
int n,k,l,i,j,size;
scanf("%d",&n);
scanf("%c",&m);
for(i=0;i<n;i++)
{
gets(arr[i]);
brr[i][0]=strlen(arr[i]);
}
for(i=0;i<n;i++)
{
k=1;
for(j=4;j<brr[i][0];j++)
{
if(arr[i][j]>='0'&&arr[i][j]<='9')
{
if(arr[i][j+1]>='0'&&arr[i][j+1]<='9')
{
brr[i][k++]=(arr[i][j]-'0')*10+(arr[i][j+1]-'0');
if(arr[i][j+2]>='0'&&arr[i][j+2]<='9')
{
brr[i][k-1]=100;
j++;
}
j++;
}
else
{
brr[i][k++]=arr[i][j]-'0';
}
}
}
}
for(l=0;l<n;l++)
{
if(arr[l][0]=='W')
Wasd(brr[l][1],brr[l][2],brr[l][3]);
if(arr[l][0]=='B')
Basd(brr[l][1],brr[l][2],brr[l][3]);
if(arr[l][0]=='T')
Tasd(brr[l][1],brr[l][2],brr[l][3]);
}
for(i=0;i<num;i++)
printf("%d\n",ans[i]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: