您的位置:首页 > 编程语言 > C语言/C++

跑马

2015-09-28 20:18 441 查看
A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0

Problem Description

Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will
regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)

 

Input

In the first line there is an integer t (1≤t≤50), indicating the number of test cases.

For each test case:

The first line contains four integers, n, A, B, L.

Next n lines, each line contains two integers: Li,Ri, which represents the interval [Li,Ri] is swamp.

1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L.

Make sure intervals are not overlapped which means Ri<Li+1 for each i (1≤i<n).

Others are all flats except the swamps.

 

Output

For each text case:

Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.

 

Sample Input

1

2 2 2 5

1 2

3 4

 

Sample Output

Case #1: 0

 
#include<stdio.h>
int main()
{
int ans=0,num=0,t,A,i,B,j,L,n,arr[101][101],power[101],use[101];
scanf("%d",&t);
while(t)
{
scanf("%d%d%d%d",&n,&A,&B,&L);
for(i=0;i<n;i++)
for(j=0;j<2;j++)
{
scanf("%d",&arr[i][j]);
if(j==1)
{
use[i]=arr[i][j]-arr[i][j-1];
}
if(i==0)
power[0]=arr[0][0];
if(i!=0)
power[i]=arr[i][0]-arr[i-1][1];
}
for(i=0;i<n;i++)
{
num=num+power[i];
num=num-use[i];
if(num<0)
{
ans=ans-num;
num=0;
}
}
printf("%d    ",ans);
t--;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c语言