您的位置:首页 > 其它

[sicily]1194. Message Flood

2015-10-13 21:38 375 查看

1194. Message Flood

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Well, how do you feel about mobile phone? Your answer would probably be something like that “It’s so convenient and benefits people a lot”. However, if you ask Merlin this question on the New Year’s Eve, he will definitely answer
“What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting messages to send! ”. Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What’s
worse, Merlin has another long name list of senders that have sent message to him, and he doesn’t want to send another message to bother them (Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send messages,
he needs to figure to how many friends are left to be sent. Please write a program to help him. 
Here is something that you should note. First, Merlin’s friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more
than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that’s why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n, m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic
strings (the length of each will be less than 10), indicating the names of Merlin’s friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders.
 The input is terminated by n=0. 

Output

For each case, print one integer in one line which indicates the number of left friends he must send. 

Sample Input


5 3

Inkfish

Henry

Carp

Max

Jericho

Carp

Max

Carp

0

Sample Output


3


这题有点意思,有几种解决方法,字典树、STL集合、或者排序查找。解题思路:在名单 list 里面除去已有的,求剩下的个数就是了。需要注意几个细节,1、大小写无关,所以需要将其统一大小写;2、查找需要使用高效的算法,不然很容易超时。如下给出两种比较简单的程序,耗时均在 0.2s 左右。据说字典树是最高效的方法,占个坑先。

法一:利用STL中 set 来处理,简单方便。
#include <iostream>
#include <cstring>
#include <set>
#include <algorithm>
using namespace std;

int main()
{
int n,m;
string tmp;
while(cin>>n && n!=0)
{
cin>>m;
set<string> list;
for(int i=0; i<n; i++)
{
cin>>tmp;
for(int j=0; j<tmp.length(); j++)
{
tmp[j] = tolower(tmp[j]);
}
list.insert(tmp);
}
for(int i=0; i<m; i++)
{
cin>>tmp;
for(int j=0; j<tmp.length(); j++)
{
tmp[j] = tolower(tmp[j]);
}
list.erase(tmp);
}
cout<<list.size()<<endl;
}
//system("pause");
return 0;
}

法二:先排序再二分查找,注意自定义了结构体,所以同时自定义了cmp 函数
#include <iostream>
#include <cstring>
#include <set>
#include <algorithm>
using namespace std;

struct list
{
string name;
int color;
};

bool cmp(struct list a, struct list b)
{
return a.name<b.name;
}
int main()
{
int n,m;
while(cin>>n && n!=0)
{
cin>>m;
string tmp;
struct list mylist
;
for(int i=0; i<n; i++)
{
cin>>tmp;
for(int j=0; j<tmp.length(); j++)
tmp[j] = tolower(tmp[j]);
mylist[i].name = tmp;
mylist[i].color = 1;
}
sort(mylist,mylist+n,cmp);// 做个排序先,自定义 cmp 函数
for(int i=0; i<m; i++)
{
cin>>tmp;
for(int j=0; j<tmp.length(); j++)
tmp[j] = tolower(tmp[j]);
int left=0, right=n-1;
int mid;
while(left <= right)//二分查找,找到了就标记 color=0;
{
mid = (left+right)/2;
if(mylist[mid].name > tmp)
{
right = mid-1;
}
else if(mylist[mid].name < tmp)
{
left = mid+1;
}
else
{
mylist[mid].color = 0;
break;
}
}
}
int count = 0;
for(int i=0; i<n; i++)
{
count = count + mylist[i].color;
}
cout<<count<<endl;
}
//system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  sicily