您的位置:首页 > 其它

hdu--1709

2015-10-08 20:28 162 查看

The Balance

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6821 Accepted Submission(s): 2800



[align=left]Problem Description[/align]
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality
of all the weights.

[align=left]Input[/align]
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality
of each weight where 1<=Ai<=100.

[align=left]Output[/align]
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.

[align=left]Sample Input[/align]

3
1 2 4
3
9 2 1


[align=left]Sample Output[/align]

0
2
4 5
题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1709
考察点:母函数
解题思路:这道题除了有一些变通需要想清楚,剩下就是套模板了.砝码可以放在天平两边,所以所给的重量不仅可以相加组合,还可以相减组合,但重物的数量只有一个.
代码如下:
#include<stdio.h>
#include<string.h>
#include<math.h>
int a[110];
int b[10100];
int c1[10100];
int c2[10100];
int main()
{
int n,i,j,k,sum;
while(scanf("%d",&n)!=EOF)
{
sum=0;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
}
memset(c1,0,sizeof(c1));
memset(c2,0,sizeof(c2));
c1[0]=1;c1[a[1]]=1;
for(i=2;i<=n;i++)
{
for(j=0;j<=sum;j++)
{
for(k=0;k+j<=sum,k<=a[i];k+=a[i])
{
c2[k+j]+=c1[j];
c2[abs(k-j)]+=c1[j];//砝码可以放两边
}
}
for(j=0;j<=sum;j++)
{
c1[j]=c2[j];
c2[j]=0;
}
}
k=0;
for(i=1;i<=sum;i++)
{
if(!c1[i])
{
b[k++]=i;
}
}
if(k)
{
printf("%d\n",k);
for(i=0;i<k-1;i++)
printf("%d ",b[i]);
printf("%d\n",b[i]);
}
else
printf("0\n");
}
return 0;
}

法二:下面的方法是通过都加一个数,使得出现负数次方的情况也考虑了
[code]#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int n,m;
int a[111];
int c1[22222],c2[22222];
const int cc=10001;

int main()
{
while(scanf("%d",&n)!=EOF)
{
int m=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
m+=a[i];
}

memset(c1,0,sizeof(c1));
memset(c2,0,sizeof(c2));

for(int i=-a[1];i<=a[1];i+=a[1])
{
c1[i+cc]=1;
}

for(int i=2;i<=n;i++)
{
for(int j=-m;j<=m;j++)
{
for(int k=-a[i];k+j<=m&&k<=a[i];k+=a[i])
{
c2[k+j+cc]+=c1[j+cc];
}
}
for(int j=-m;j<=m;j++)
{
c1[j+cc]=c2[j+cc];
c2[j+cc]=0;
}
}

int aas[10000]={0};
int ans=0;
for(int i=0;i<=m;i++)
{
if(c1[i+cc]||c1[-i+cc]) ;
else
{
aas[ans]=i;
ans++;
}
}

printf("%d\n",ans);
for(int i=0;i<ans;i++)
{
if(i==0)
printf("%d",aas[i]);
else
printf(" %d",aas[i]);
}
if(ans)
putchar(10);

}

return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: