您的位置:首页 > 编程语言 > Go语言

【PAT】1092. To Buy or Not to Buy (20)

2015-10-11 21:03 387 查看
Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether
a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is "Yes", please tell her the number of extra beads she has to buy; or if the answer is "No", please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary
beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.



Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is "Yes", then also output the number of extra beads Eva has to buy; or if the answer is "No", then also output the number of beads missing from the string. There must be exactly 1 space between
the answer and the number.
Sample Input 1:
ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:
Yes 8

Sample Input 2:
ppRYYGrrYB225
YrR8RrY

Sample Output 1:

No 2

分析:简单题。给出俩个字符串a,b。 问a中是否包含b的所有字符,如果是,列出a中多余的字符个数;如果不是,列车a中还缺少的字符个数。  直接暴搜就能够解决。

#include <iostream>
#include <string.h>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
#define MAX 1001
int flag[MAX];

int main(int argc, char** argv) {
string a, b;
cin>>a>>b;
memset(flag,0,sizeof(flag));

int i, j, cnt, missCnt;
bool find = true;
cnt = 0;
missCnt = 0;
for(i=0; i<b.size(); i++){
for(j=0; j<a.size(); j++){
if( (flag[j]==0)&&(a[j]==b[i]) ){
cnt++;
flag[j] = 1;
break;
}
}
if(j >= a.size()){
//没找到
find = false;
missCnt++;
}
}
if(find){
cout<<"Yes "<<a.size()-cnt<<endl;
}else{
cout<<"No "<<missCnt<<endl;;
}
return 0;
}


也可以用map来处理:

#include <iostream>
#include <string>
#include <vector>
#include <map>
using namespace std;

int main(int argc, char** argv) {
string str,want;
cin>>str>>want;
map<char, int> m;
int i;
for(i=0; i<want.size(); i++){
if(m.find(want[i])==m.end()){
m.insert(make_pair(want[i],1));
}else{
m[want[i]]++;
}
}
for(i=0; i<str.size(); i++){
if(m.find(str[i])!=m.end() && m[str[i]]>0){
m[str[i]]--;
}
}
int total = 0;
for(i=0; i<want.size(); i++){

total += m[want[i]];
m[want[i]] = 0;
}
if(total == 0){
printf("Yes %d\n",str.size()-want.size());
}else{
printf("No %d\n",total);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT algorithm 字符串