您的位置:首页 > 其它

The Pilots Brothers' refrigerator(dfs)

2015-09-29 20:26 274 查看
B - The Pilots Brothers' refrigerator
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
2965

Appoint description: 
System Crawler  (2015-09-28)

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i,
j]
 (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is
initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions,
you may give any one of them.

Sample Input

-+--
----
----
-+--


Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4


  这题要用G++提交才能A,用c++会TLE.
看了看别人代码后发现有用异或来更改数组值的,结果我试了一下,差别很明显。自己还一直想优化算法,结果异或就是最好的优化了,只能怪自己太笨了。



AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
using namespace std;
int a[5][5],step,flag;
pair<int,int> x;
vector< pair<int,int> > stack;
void flip(int row,int col)
{
for(int i=1;i<=4;++i){
a[row][i]=!a[row][i];
a[i][col]=!a[i][col];
}
a[row][col]=!a[row][col];
}
bool jugde()
{
for(int i=1;i<=4;++i){
for(int j=1;j<=4;++j){
if(a[i][j]!=1)
return false;
}
}
return true;
}
void dfs(int row,int col,int deep)
{
if(flag)return;
x.first = row,x.second=col;
if(deep==step){
flag = jugde();
return;
}
if(row==5||flag){
return;
}
flip(row,col);
if(col<4){
stack.push_back(x);
dfs(row,col+1,deep+1);
}
else{
stack.push_back(x);
dfs(row+1,1,deep+1);
}
flip(row,col);
if(flag)return;
stack.pop_back();
if(col<4){
dfs(row,col+1,deep);
}
else{
dfs(row+1,1,deep);
}
/*stack.pop_back();*/
return;
}
int main()
{
/*freopen("input.txt","r",stdin);*/
int i,j;
char c;
for(i=1;i<=4;++i){
for(j=1;j<=4;++j){
scanf(" %c",&c);
if(c=='+'){
a[i][j]=0;
}
else{
a[i][j] = 1;
}
}
}
for(step=1;step<=16;++step){
dfs(1,1,0);
if(flag)break;
}
printf("%d\n",step);
for(i=0;i<(int)stack.size();++i)
printf("%d %d\n",stack[i].first,stack[i].second);
return 0;
}


高效代码:

转自poj讨论:

参考高手的高效解法:
> 证明:要使一个为'+'的符号变为'-',必须其相应的行和列的操作数为奇数;可以证明,如果'+'位置对应的行和列上每一个位置都进行一次操作,则整个图只有这一'+'位置的符号改变,其余都不会改变.
> 设置一个4*4的整型数组,初值为零,用于记录每个点的操作数,那么在每个'+'上的行和列的的位置都加1,得到结果模2(因为一个点进行偶数次操作的效果和没进行操作一样,这就是楼上说的取反的原理),然后计算整型数组中一的
> 个数即为操作数,一的位置为要操作的位置(其他原来操作数为偶数的因为操作并不发生效果,因此不进行操作)
*********************************
此上证其可以按以上步骤使数组中值都为‘-’
********************************
在上述证明中将所有的行和列的位置都加1后,在将其模2之前,对给定的数组状态,将所有的位置操作其所存的操作数个次数,举例,如果a[i][j]==n,则对(i,j)操作n次,当所有的操作完后,即全为‘-’的数组。
其实就是不模2的操作,作了许多的无用功。
以上的操作次序对结果无影响,如果存在一个最小的步骤,则此步骤一定在以上操作之中。(简单说下:因为以上操作已经包含了所有可改变欲改变位置的操作了)
而模2后的操作是去掉了所有无用功之后的操作,此操作同样包含最小步骤。
但模2后的操作去掉任何一个或几个步骤后,都不可能再得到全为‘-’的。(此同样可证明:因为操作次序无影响,先进行最小步骤,得到全为‘-’,如果还剩下m步,则在全为‘-’的数组状态下进行这m步操作后还得到一个全为
‘-’的数组状态,此只能是在同一个位置进行偶数次操作,与前文模2后矛盾,所以m=0),因此模2后的操作即为最小步骤的操作。


#include <iostream>
using namespace std;

bool mark[4][4];
char s[4][4];

int main()
{
int i,j,k;
int ci[16],cj[16];
int nas = 0;
memset(mark,0,sizeof(mark));
for(i = 0;i < 4;i++)
cin >> s[i];
for(i = 0;i < 4;i++)
for(j = 0;j < 4;j++)
{
char c = s[i][j];
if(c == '+')
{
mark[i][j] = !mark[i][j];
for(k = 0;k < 4;k++)
{
mark[i][k] = !mark[i][k];
mark[k][j] = !mark[k][j];
}
}

}
for(i = 0;i < 4;i++)
for(j = 0;j < 4;j++)
if(mark[i][j] == true)
{
ci[nas] = i + 1;
cj[nas] = j + 1;
nas ++;
}
printf("%d\n",nas);
for(i = 0;i < nas;i++)
{
printf("%d %d\n",ci[i],cj[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dfs