您的位置:首页 > 其它

hdoj Constructing Roads In JGShining's Kingdom (LIS变形+二分)

2015-09-29 18:14 387 查看

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19611    Accepted Submission(s): 5544


[align=left]Problem Description[/align]
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource.
You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor
cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

 

[align=left]Input[/align]
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to
the end of file.

 

[align=left]Output[/align]
For each test case, output the result in the form of sample.

You should tell JGShining what's the maximal number of road(s) can be built.

 

[align=left]Sample Input[/align]

2
1 2
2 1
3
1 2
2 3
3 1

 

[align=left]Sample Output[/align]

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

Hint
Huge input, scanf is recommended.
 
#include<stdio.h>
#include<string.h>
int a[500010];
int b[500010];
int main()
{
int n,i,j;
int x,y;
int l,r,mid;
int cnt=1;
int top;
while(scanf("%d",&n)!=EOF)
{
for(i=1;i<=n;i++)
{
scanf("%d%d",&x,&y);
a[x]=y;
}
b[1]=a[1];top=1;
for(i=1;i<=n;i++)
{
l=1;r=top;
while(l<=r)
{
mid=(l+r)/2;
if(b[mid]>=a[i])
r=mid-1;
else
l=mid+1;
}
b[l]=a[i];
if(l>top)
top++;
}
printf("Case %d:\n",cnt++);
if(top>1)
printf("My king, at most %d roads can be built.\n\n",top);
else
printf("My king, at most %d road can be built.\n\n",top);
}
return 0;
}

  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: