您的位置:首页 > 其它

HDU 5476 Explore Track of Point(平面几何)

2015-09-27 11:06 330 查看


Explore Track of Point

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 263    Accepted Submission(s): 100


Problem Description

In Geometry, the problem of track is very interesting. Because in some cases, the track of point may be beautiful curve. For example, in polar Coordinate system,ρ=cos3θ is
like rose, ρ=1−sinθ is
a Cardioid, and so on. Today, there is a simple problem about it which you need to solve.

Give you a triangle ΔABC and
AB = AC. M is the midpoint of BC. Point P is in ΔABC and
makes min{∠MPB+∠APC,∠MPC+∠APB} maximum.
The track of P is Γ.
Would you mind calculating the length of Γ?

Given the coordinate of A, B, C, please output the length of Γ.

 

Input

There are T (1≤T≤104)
test cases. For each case, one line includes six integers the coordinate of A, B, C in order. It is guaranteed that AB = AC and three points are not collinear. All coordinates do not exceed 104 by
absolute value.

 

Output

For each case, first please output "Case #k: ", k is the number of test case. See sample output for more detail. Then, please output the length of Γ with
exactly 4 digits after the decimal point.

 

Sample Input

1
0 1 -1 0 1 0

 

Sample Output

Case #1: 3.2214

 

Source

2015 ACM/ICPC Asia Regional Shanghai Online

解题思路:

最后的答案为过点b和点c与ab和ac相切的圆bc这一段劣弧加上三角形的高,根据相似三角形求圆的半径和劣弧所对应的圆心角即可

 
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <algorithm>
using namespace std;
const double pi = acos(-1);
double ax, ay, bx, by, cx, cy;
int main()
{
int T, kcase = 1;
scanf("%d", &T);
while(T--)
{
scanf("%lf%lf%lf%lf%lf%lf", &ax, &ay, &bx, &by, &cx, &cy);
double ab = sqrt((ax - bx) * (ax - bx) + (ay - by) * (ay - by));
double ac = sqrt((ax - cx) * (ax - cx) + (ay - cy) * (ay - cy));
double bc = sqrt((bx - cx) * (bx - cx) + (by - cy) * (by - cy));
double am = sqrt(ac * ac - 0.5 * bc * 0.5 * bc);
double acb = asin(am / ac);
double cen = 2 * acb;
double r = (0.5 * ac * bc) / am;
//cout << r << endl;
//cout << cen << endl;
double ans = 2 * pi * r * (cen / (2 * pi));
//cout << ans << endl;
ans += am;
printf("Case #%d: %.4lf\n", kcase++, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: