您的位置:首页 > 产品设计 > UI/UE

General Problem Solving Techniques [Examples]~C

2015-09-26 13:57 471 查看
A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

Input

There is a number of inputs. Each input begins with n (n < 1000001), the number of people in the village. n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3

100

100

100

4

1

2

5

4

Sample Output

0

4

解题思路:这是一道分硬币的题目。首先,最终每个人的金币数量可以计算出来。我可以假设现在每个人手中有a【i】枚金币,如果第一个人给第二个人x枚金币,然后第二个人给第一个人y枚金币,其实就是说地二个人给了第一个人x2枚金币,注意这里的x2有正负之分。然后可以找规律,会发现可以转换成一个数轴上的距离问题。具体可以参考代码。

程序代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
const int N=1000010;
int a[N],b[N];
int f(int a,int b){
if(a < b){
return b - a;
}
else{
return a - b;
}
}
int main()
{
long long n,i,sum,m,mini;
while(scanf("%lld",&n)!=EOF)
{
sum=0;
mini=0;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
}
m=sum/n;
b[0]=0;
for(i=1;i<n;i++)
b[i]=b[i-1]+a[i]-m;
sort(b,b+n);
long long x=b[n/2];
for(i=0;i<n;i++)
mini+=f(x,b[i]);
printf("%lld\n",mini);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: