您的位置:首页 > 其它

HDU 5443 The Water Problem(RMQ)2014 多校

2015-09-25 22:46 323 查看


The Water Problem

Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 825 Accepted Submission(s): 666



Problem Description

In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a1,a2,a3,...,anrepresenting
the size of the water source. Given a set of queries each containing 2 integers l and r,
please find out the biggest water source between al and ar.



Input

First you are given an integer T(T≤10) indicating
the number of test cases. For each test case, there is a number n(0≤n≤1000) on
a line representing the number of water sources. n integers
follow, respectively a1,a2,a3,...,an,
and each integer is in {1,...,106}.
On the next line, there is a number q(0≤q≤1000) representing
the number of queries. After that, there will be q lines
with two integers l and r(1≤l≤r≤n) indicating
the range of which you should find out the biggest water source.



Output

For each query, output an integer representing the size of the biggest water source.



Sample Input

3
1
100
1
1 1
5
1 2 3 4 5
5
1 2
1 3
2 4
3 4
3 5
3
1 999999 1
4
1 1
1 2
2 3
3 3




Sample Output

100
2
3
4
4
5
1
999999
999999
1




题意:输入N个数,然后q组询问,每组询问输出从L到R区间内的最大值,裸的RMQ。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <cctype>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <sstream>
#include <fstream>
#define debug "output for debug\n"
#define pi (acos(-1.0))
#define eps (1e-8)
#define inf 0x3f3f3f3f
#define ll long long int
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
using namespace std;
int n,q;
int a[1005][1005];
int l,r;
int b[1005][1005];
void rmp(int n)
{
    for(int i=1;i<log2(n);i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(j+(1<<i)-1<=n)
                a[i][j]=max(a[i-1][j],a[i-1][j+(1<<i>>1)]);
        }
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[0][i]);
        }
        rmp(n);
        scanf("%d",&q);
        while(q--)
        {
            scanf("%d%d",&l,&r);
            int k=(int)log2(r-l+1.0);
            printf("%d\n",max(a[k][l],a[k][r-(1<<k)+1]));
        }
    }
    return 0;
}


题目链接:点击打开链接
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: